%global _empty_manifest_terminate_build 0
Name:		python-skutil
Version:	0.0.18
Release:	1
Summary:	Utilities for scikit-learn.
License:	MIT License
URL:		https://github.com/shaypal5/skutil
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/be/d9/4ba3c9182007caf77d6c12fa9dbe176f5ec6ef058cc7a979e77206bac5ba/skutil-0.0.18.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-decore
Requires:	python3-pytest
Requires:	python3-scikit-learn
Requires:	python3-coverage
Requires:	python3-pytest-cov
Requires:	python3-pandas
Requires:	python3-pdutil
Requires:	python3-numpy
Requires:	python3-decore

%description
  pip install skutil

%package -n python3-skutil
Summary:	Utilities for scikit-learn.
Provides:	python-skutil
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-skutil
  pip install skutil

%package help
Summary:	Development documents and examples for skutil
Provides:	python3-skutil-doc
%description help
  pip install skutil

%prep
%autosetup -n skutil-0.0.18

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-skutil -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.18-1
- Package Spec generated