%global _empty_manifest_terminate_build 0
Name:		python-shakenfist-client
Version:	0.6.5
Release:	1
Summary:	Shaken Fist: an opinionated minimal cloud
License:	Apache2
URL:		https://madebymikal.com/shakenfist
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/21/cd/1900194a6803c21a2eac91701022bcae248e501bdba97705eeabc426205c/shakenfist-client-0.6.5.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-pbr
Requires:	python3-prettytable
Requires:	python3-requests
Requires:	python3-shakenfist-utilities
Requires:	python3-tqdm

%description
This is a python REST API client and command line client for the minimal cloud [Shaken Fist](https://github.com/shakenfist/shakenfist).
The library is a complete interface to the Shaken Fist HTTP API.

%package -n python3-shakenfist-client
Summary:	Shaken Fist: an opinionated minimal cloud
Provides:	python-shakenfist-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-shakenfist-client
This is a python REST API client and command line client for the minimal cloud [Shaken Fist](https://github.com/shakenfist/shakenfist).
The library is a complete interface to the Shaken Fist HTTP API.

%package help
Summary:	Development documents and examples for shakenfist-client
Provides:	python3-shakenfist-client-doc
%description help
This is a python REST API client and command line client for the minimal cloud [Shaken Fist](https://github.com/shakenfist/shakenfist).
The library is a complete interface to the Shaken Fist HTTP API.

%prep
%autosetup -n shakenfist-client-0.6.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-shakenfist-client -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.5-1
- Package Spec generated