%global _empty_manifest_terminate_build 0
Name:		python-sky
Version:	0.0.201
Release:	1
Summary:	AI powered scraping in Python 3
License:	BSD
URL:		https://github.com/kootenpv/sky
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2e/af/c5ced6a2cad15de80f34fccbf9e9ed8a078e002f7f67fe1b6877ce1aadc0/sky-0.0.201.tar.gz
BuildArch:	noarch

Requires:	python3-lxml
Requires:	python3-tldextract
Requires:	python3-requests
Requires:	python3-justext
Requires:	python3-langdetect
Requires:	python3-dateutil
Requires:	python3-beautifulsoup4
Requires:	python3-aiohttp
Requires:	python3-tornado

%description


%package -n python3-sky
Summary:	AI powered scraping in Python 3
Provides:	python-sky
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sky


%package help
Summary:	Development documents and examples for sky
Provides:	python3-sky-doc
%description help


%prep
%autosetup -n sky-0.0.201

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sky -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.201-1
- Package Spec generated