%global _empty_manifest_terminate_build 0
Name:		python-rotest
Version:	8.3.1
Release:	1
Summary:	Resource oriented testing framework
License:	MIT
URL:		https://github.com/gregoil/rotest
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c8/1e/07a491bb7f6bf7eb5b6b0ad7b28e317d488392a30c7eef7e665f068e8d78/rotest-8.3.1.tar.gz
BuildArch:	noarch

Requires:	python3-django
Requires:	python3-py
Requires:	python3-ipdbugger
Requires:	python3-xlwt
Requires:	python3-attrdict
Requires:	python3-pyyaml
Requires:	python3-psutil
Requires:	python3-colorama
Requires:	python3-termcolor
Requires:	python3-jsonschema
Requires:	python3-basicstruct
Requires:	python3-future
Requires:	python3-swaggapi
Requires:	python3-cached-property
Requires:	python3-channels
Requires:	python3-websocket-client
Requires:	python3-statistics
Requires:	python3-pytest
Requires:	python3-pytest-django
Requires:	python3-pytest-cov
Requires:	python3-mock
Requires:	python3-pyfakefs
Requires:	python3-xlrd
Requires:	python3-pathlib2
Requires:	python3-flake8
Requires:	python3-pylint
Requires:	python3-waiting

%description
`Watch the demo <https://asciinema.org/a/u3B3aMmkipUDLSgTiv1thiBpP>`_
Rotest is a resource oriented testing framework, for writing system or
integration tests.
Rotest is based on Python's `unittest` module and on the Django framework.
It enables defining simple abstracted components in the system, called
resources. The resources may be DUT (devices under test) or they may help
the test process. The tests look very much like tests written using the
builtin module `unittest`.

%package -n python3-rotest
Summary:	Resource oriented testing framework
Provides:	python-rotest
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rotest
`Watch the demo <https://asciinema.org/a/u3B3aMmkipUDLSgTiv1thiBpP>`_
Rotest is a resource oriented testing framework, for writing system or
integration tests.
Rotest is based on Python's `unittest` module and on the Django framework.
It enables defining simple abstracted components in the system, called
resources. The resources may be DUT (devices under test) or they may help
the test process. The tests look very much like tests written using the
builtin module `unittest`.

%package help
Summary:	Development documents and examples for rotest
Provides:	python3-rotest-doc
%description help
`Watch the demo <https://asciinema.org/a/u3B3aMmkipUDLSgTiv1thiBpP>`_
Rotest is a resource oriented testing framework, for writing system or
integration tests.
Rotest is based on Python's `unittest` module and on the Django framework.
It enables defining simple abstracted components in the system, called
resources. The resources may be DUT (devices under test) or they may help
the test process. The tests look very much like tests written using the
builtin module `unittest`.

%prep
%autosetup -n rotest-8.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rotest -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 8.3.1-1
- Package Spec generated