%global _empty_manifest_terminate_build 0
Name:		python-clease
Version:	1.0.6
Release:	1
Summary:	CLuster Expansion in Atomistic Simulation Environment
License:	MPL-2.0
URL:		https://gitlab.com/computationalmaterials/clease/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/12/4c/97f526c10f302580d117c83fcebe6bb008f87cf4d52f642937bf2341589a/clease-1.0.6.tar.gz
BuildArch:	noarch


%description
# CLEASE

[![coverage](https://gitlab.com/computationalmaterials/clease/badges/master/coverage.svg)](https://gitlab.com/computationalmaterials/clease/)
[![PyPI version](https://badge.fury.io/py/clease.svg)](https://badge.fury.io/py/clease)
[![Conda](https://img.shields.io/conda/vn/conda-forge/clease)](https://anaconda.org/conda-forge/clease)
[![Documentation Status](https://readthedocs.org/projects/clease/badge/?version=latest)](https://clease.readthedocs.io/en/latest/?badge=latest)

CLuster Expansion in Atomic Simulation Environment (CLEASE) is a package that automates the cumbersome setup and construction procedure of cluster expansion (CE). It provides a comprehensive list of tools for specifying parameters for CE, generating training structures, fitting effective cluster interaction (ECI) values and running Monte Carlo simulations. A detailed description of the package can be found in the [documentation](https://clease.readthedocs.io/) and our [paper](https://doi.org/10.1088/1361-648X/ab1bbc).

For information on how to contribute to CLEASE, please see the [contributing](CONTRIBUTING.md) file.

# Installation

Install the CLEASE code by executing

```bash
pip install clease
```

Alternative, CLEASE is also available through anaconda on [conda](https://conda.io) via [conda-forge](https://conda-forge.org/).
We recommend installing CLEASE via conda on windows machines in order to simplify compilations, as pip tends to have
a hard time compiling the C++ code. Install into your conda environment:

```sh
conda install -c conda-forge clease
```
## Graphical User Interface

Clease has a stand-alone jupyter notebook GUI, which is capable of performing most
of the standard CE routines. It can be found [here](https://clease-gui.readthedocs.io).

CLEASE GUI can be installed from PyPI or anaconda using one of the two following commands.

### PyPI

```bash
pip install clease[gui]
```

### Anaconda

```bash
conda install -c conda-forge clease-gui
```

## Development

If you are a developer you might want to install CLEASE by executing the following command in the root folder of the project

```bash
pip install -e .
```

In order to run the tests, the testing dependencies should be installed. They can be installed with the extra
`test` option

```bash
pip install .[test]
```

There is an additional option for development purposes, `dev`, which contains some convenience packages.
All of the extras options can be installed via the `all` option,
i.e.

```bash
pip install .[all]
```

Note, that if you are using `zsh`, you need to [escape the argument](https://stackoverflow.com/a/30539963), e.g.

```bash
pip install '.[all]'
```

## Troubleshooting

If you are running on Mac and get the error

```bash
fatal error: 'ios' file not found
```

try this before installing

```bash
export MACOSX_DEPLOYMENT_TARGET=10.14
```


%package -n python3-clease
Summary:	CLuster Expansion in Atomistic Simulation Environment
Provides:	python-clease
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-clease
# CLEASE

[![coverage](https://gitlab.com/computationalmaterials/clease/badges/master/coverage.svg)](https://gitlab.com/computationalmaterials/clease/)
[![PyPI version](https://badge.fury.io/py/clease.svg)](https://badge.fury.io/py/clease)
[![Conda](https://img.shields.io/conda/vn/conda-forge/clease)](https://anaconda.org/conda-forge/clease)
[![Documentation Status](https://readthedocs.org/projects/clease/badge/?version=latest)](https://clease.readthedocs.io/en/latest/?badge=latest)

CLuster Expansion in Atomic Simulation Environment (CLEASE) is a package that automates the cumbersome setup and construction procedure of cluster expansion (CE). It provides a comprehensive list of tools for specifying parameters for CE, generating training structures, fitting effective cluster interaction (ECI) values and running Monte Carlo simulations. A detailed description of the package can be found in the [documentation](https://clease.readthedocs.io/) and our [paper](https://doi.org/10.1088/1361-648X/ab1bbc).

For information on how to contribute to CLEASE, please see the [contributing](CONTRIBUTING.md) file.

# Installation

Install the CLEASE code by executing

```bash
pip install clease
```

Alternative, CLEASE is also available through anaconda on [conda](https://conda.io) via [conda-forge](https://conda-forge.org/).
We recommend installing CLEASE via conda on windows machines in order to simplify compilations, as pip tends to have
a hard time compiling the C++ code. Install into your conda environment:

```sh
conda install -c conda-forge clease
```
## Graphical User Interface

Clease has a stand-alone jupyter notebook GUI, which is capable of performing most
of the standard CE routines. It can be found [here](https://clease-gui.readthedocs.io).

CLEASE GUI can be installed from PyPI or anaconda using one of the two following commands.

### PyPI

```bash
pip install clease[gui]
```

### Anaconda

```bash
conda install -c conda-forge clease-gui
```

## Development

If you are a developer you might want to install CLEASE by executing the following command in the root folder of the project

```bash
pip install -e .
```

In order to run the tests, the testing dependencies should be installed. They can be installed with the extra
`test` option

```bash
pip install .[test]
```

There is an additional option for development purposes, `dev`, which contains some convenience packages.
All of the extras options can be installed via the `all` option,
i.e.

```bash
pip install .[all]
```

Note, that if you are using `zsh`, you need to [escape the argument](https://stackoverflow.com/a/30539963), e.g.

```bash
pip install '.[all]'
```

## Troubleshooting

If you are running on Mac and get the error

```bash
fatal error: 'ios' file not found
```

try this before installing

```bash
export MACOSX_DEPLOYMENT_TARGET=10.14
```


%package help
Summary:	Development documents and examples for clease
Provides:	python3-clease-doc
%description help
# CLEASE

[![coverage](https://gitlab.com/computationalmaterials/clease/badges/master/coverage.svg)](https://gitlab.com/computationalmaterials/clease/)
[![PyPI version](https://badge.fury.io/py/clease.svg)](https://badge.fury.io/py/clease)
[![Conda](https://img.shields.io/conda/vn/conda-forge/clease)](https://anaconda.org/conda-forge/clease)
[![Documentation Status](https://readthedocs.org/projects/clease/badge/?version=latest)](https://clease.readthedocs.io/en/latest/?badge=latest)

CLuster Expansion in Atomic Simulation Environment (CLEASE) is a package that automates the cumbersome setup and construction procedure of cluster expansion (CE). It provides a comprehensive list of tools for specifying parameters for CE, generating training structures, fitting effective cluster interaction (ECI) values and running Monte Carlo simulations. A detailed description of the package can be found in the [documentation](https://clease.readthedocs.io/) and our [paper](https://doi.org/10.1088/1361-648X/ab1bbc).

For information on how to contribute to CLEASE, please see the [contributing](CONTRIBUTING.md) file.

# Installation

Install the CLEASE code by executing

```bash
pip install clease
```

Alternative, CLEASE is also available through anaconda on [conda](https://conda.io) via [conda-forge](https://conda-forge.org/).
We recommend installing CLEASE via conda on windows machines in order to simplify compilations, as pip tends to have
a hard time compiling the C++ code. Install into your conda environment:

```sh
conda install -c conda-forge clease
```
## Graphical User Interface

Clease has a stand-alone jupyter notebook GUI, which is capable of performing most
of the standard CE routines. It can be found [here](https://clease-gui.readthedocs.io).

CLEASE GUI can be installed from PyPI or anaconda using one of the two following commands.

### PyPI

```bash
pip install clease[gui]
```

### Anaconda

```bash
conda install -c conda-forge clease-gui
```

## Development

If you are a developer you might want to install CLEASE by executing the following command in the root folder of the project

```bash
pip install -e .
```

In order to run the tests, the testing dependencies should be installed. They can be installed with the extra
`test` option

```bash
pip install .[test]
```

There is an additional option for development purposes, `dev`, which contains some convenience packages.
All of the extras options can be installed via the `all` option,
i.e.

```bash
pip install .[all]
```

Note, that if you are using `zsh`, you need to [escape the argument](https://stackoverflow.com/a/30539963), e.g.

```bash
pip install '.[all]'
```

## Troubleshooting

If you are running on Mac and get the error

```bash
fatal error: 'ios' file not found
```

try this before installing

```bash
export MACOSX_DEPLOYMENT_TARGET=10.14
```


%prep
%autosetup -n clease-1.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-clease -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.6-1
- Package Spec generated