%global _empty_manifest_terminate_build 0
Name: python-pyrlprob
Version: 2.0.3
Release: 1
Summary: Train Gym-derived environments in Python/C++ through Ray RLlib
License: MIT License
URL: https://github.com/LorenzoFederici/pyrlprob
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/87/90/b863fca4ffb5ea8dc8de9c8c27c15ff85488fa9c146413ea2a77659189cf/pyrlprob-2.0.3.tar.gz
BuildArch: noarch
%description
![GitHub Repo stars](https://img.shields.io/github/stars/LorenzoFederici/pyrlprob?style=social)
![GitHub last commit](https://img.shields.io/github/last-commit/LorenzoFederici/pyrlprob)
![GitHub Release Date](https://img.shields.io/github/release-date/LorenzoFederici/pyrlprob)
![GitHub release (latest by date)](https://img.shields.io/github/v/release/LorenzoFederici/pyrlprob)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/pyrlprob)
PyRLprob is an open-source python library for training, evaluation, and postprocessing of [Gym](https://gym.openai.com/)-based environments, written in Python, through [Ray-RLlib](https://docs.ray.io/en/master/rllib.html) reinforcement learning library.
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install the latest stable release of pyRLprob, with all its dependencies:
```bash
pip install pyrlprob
```
To test if the package is installed correctly, run the following tests:
```python
from pyrlprob.tests import *
test_train_py()
test_train_eval_py()
```
If the code exits without errors, a folder named `results/` with the test results will be created in your current directory.
## User Guide
[Latest user guide](https://drive.google.com/file/d/1bNs2g50cxtmAGhhB1_Kf3hX8pdkbCplZ/view?usp=share_link).
## Credits
pyRLprob has been created by [Lorenzo Federici](https://github.com/LorenzoFederici) in 2021.
For any problem, clarification or suggestion, you can contact the author at [lorenzof@arizona.edu](mailto:lorenzof@arizona.edu).
## License
The package is under the [MIT](https://choosealicense.com/licenses/mit/) license.
%package -n python3-pyrlprob
Summary: Train Gym-derived environments in Python/C++ through Ray RLlib
Provides: python-pyrlprob
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyrlprob
![GitHub Repo stars](https://img.shields.io/github/stars/LorenzoFederici/pyrlprob?style=social)
![GitHub last commit](https://img.shields.io/github/last-commit/LorenzoFederici/pyrlprob)
![GitHub Release Date](https://img.shields.io/github/release-date/LorenzoFederici/pyrlprob)
![GitHub release (latest by date)](https://img.shields.io/github/v/release/LorenzoFederici/pyrlprob)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/pyrlprob)
PyRLprob is an open-source python library for training, evaluation, and postprocessing of [Gym](https://gym.openai.com/)-based environments, written in Python, through [Ray-RLlib](https://docs.ray.io/en/master/rllib.html) reinforcement learning library.
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install the latest stable release of pyRLprob, with all its dependencies:
```bash
pip install pyrlprob
```
To test if the package is installed correctly, run the following tests:
```python
from pyrlprob.tests import *
test_train_py()
test_train_eval_py()
```
If the code exits without errors, a folder named `results/` with the test results will be created in your current directory.
## User Guide
[Latest user guide](https://drive.google.com/file/d/1bNs2g50cxtmAGhhB1_Kf3hX8pdkbCplZ/view?usp=share_link).
## Credits
pyRLprob has been created by [Lorenzo Federici](https://github.com/LorenzoFederici) in 2021.
For any problem, clarification or suggestion, you can contact the author at [lorenzof@arizona.edu](mailto:lorenzof@arizona.edu).
## License
The package is under the [MIT](https://choosealicense.com/licenses/mit/) license.
%package help
Summary: Development documents and examples for pyrlprob
Provides: python3-pyrlprob-doc
%description help
![GitHub Repo stars](https://img.shields.io/github/stars/LorenzoFederici/pyrlprob?style=social)
![GitHub last commit](https://img.shields.io/github/last-commit/LorenzoFederici/pyrlprob)
![GitHub Release Date](https://img.shields.io/github/release-date/LorenzoFederici/pyrlprob)
![GitHub release (latest by date)](https://img.shields.io/github/v/release/LorenzoFederici/pyrlprob)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/pyrlprob)
PyRLprob is an open-source python library for training, evaluation, and postprocessing of [Gym](https://gym.openai.com/)-based environments, written in Python, through [Ray-RLlib](https://docs.ray.io/en/master/rllib.html) reinforcement learning library.
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install the latest stable release of pyRLprob, with all its dependencies:
```bash
pip install pyrlprob
```
To test if the package is installed correctly, run the following tests:
```python
from pyrlprob.tests import *
test_train_py()
test_train_eval_py()
```
If the code exits without errors, a folder named `results/` with the test results will be created in your current directory.
## User Guide
[Latest user guide](https://drive.google.com/file/d/1bNs2g50cxtmAGhhB1_Kf3hX8pdkbCplZ/view?usp=share_link).
## Credits
pyRLprob has been created by [Lorenzo Federici](https://github.com/LorenzoFederici) in 2021.
For any problem, clarification or suggestion, you can contact the author at [lorenzof@arizona.edu](mailto:lorenzof@arizona.edu).
## License
The package is under the [MIT](https://choosealicense.com/licenses/mit/) license.
%prep
%autosetup -n pyrlprob-2.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyrlprob -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 2.0.3-1
- Package Spec generated