%global _empty_manifest_terminate_build 0
Name: python-aa-blueprints
Version: 1.3.0
Release: 1
Summary: Blueprint Library plugin for Alliance Auth
License: GPL
URL: https://gitlab.com/eclipse-expeditions/aa-blueprints
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6a/96/f805fbce46d705fb505f057a6cc8b1d2d72f62c3c44776158a0381d3f62a/aa-blueprints-1.3.0.tar.gz
BuildArch: noarch
Requires: python3-allianceauth
Requires: python3-django-eveuniverse
Requires: python3-dj-datatables-view
Requires: python3-allianceauth-app-utils
%description
# AA Blueprints
This is an blueprints library app for [Alliance Auth](https://gitlab.com/allianceauth/allianceauth) (AA) that can be used to list blueprints for your corporation or alliance.






## Overview
### Features
- Lists all blueprints owned by corporation or alliance (configurable with permissions)
- Manage user requests for making copies of blueprints
>**Hint**
Blueprints sends Auth notifications to inform users about blueprint requests. If you like to get those as direct messages on Discord please consider also installing [Discord Notify](https://gitlab.com/ErikKalkoken/aa-discordnotify).
## Screenshots
### Library

#### View Blueprint

#### Create a Request

#### My Requests

#### Open Requests

#### Manage Blueprints

## Installation
### Requirements
AA Blueprints needs the app [django-eveuniverse](https://gitlab.com/ErikKalkoken/django-eveuniverse) to function. Please make sure it is installed before before continuing.
### Steps
#### Step 1 - Install the Package
Make sure you are in the virtual environment (venv) of your Alliance Auth installation. Then install the newest release from PyPI:
`pip install aa-blueprints`
#### Step 2 - Configure AA
- Add 'blueprints' to `INSTALLED_APPS` in `settings/local.py`.
- Add the following automated task definition:
```python
CELERYBEAT_SCHEDULE['blueprints_update_all_blueprints'] = {
'task': 'blueprints.tasks.update_all_blueprints',
'schedule': crontab(minute=0, hour='*/3'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_industry_jobs'] = {
'task': 'blueprints.tasks.update_all_industry_jobs',
'schedule': crontab(minute=0, hour='*'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_locations'] = {
'task': 'blueprints.tasks.update_all_locations',
'schedule': crontab(minute=0, hour='*/12'),
}
```
#### Step 3 - Finalize App installation
Run migrations & copy static files:
```bash
python manage.py migrate
python manage.py collectstatic
```
Restart your supervisor services for Auth
#### Step 4 - Update EVE Online API Application
Update the Eve Online API app used for authentication in your AA installation to include the following scopes:
- `esi-assets.read_assets.v1`
- `esi-assets.read_corporation_assets.v1`
- `esi-characters.read_blueprints.v1`
- `esi-corporations.read_blueprints.v1`
- `esi-industry.read_character_jobs.v1`
- `esi-industry.read_corporation_jobs.v1`
- `esi-universe.read_structures.v1`
#### Step 5 - Data import
Load EVE Online type data from ESI:
```bash
python manage.py blueprints_load_types
```
## Permissions
| ID | Description | Notes |
|----------------------------------|----------------------------------------------|--------------------------------------------------------------------------------|
| `basic_access` | Can access this app | |
| `request_blueprints` | Can request blueprints | |
| `manage_requests` | Can review and accept blueprint requests | |
| `add_personal_blueprint_owner` | Can add personal blueprint owners | |
| `add_corporate_blueprint_owner` | Can add corporate blueprint owners | :warning: Should only be given to directors or the CEO. |
| `view_alliance_blueprints` | Can view alliance's blueprints | |
| `view_industry_jobs` | Can view details about running industry jobs | :warning: This permission will let someone see _all_ industry job information. |
## Upgrading
See [UPGRADING.md](UPGRADING.md).
## Authors
The main authors (in alphabetical order):
- [Erik Kalkoken](https://gitlab.com/ErikKalkoken)
- [Rebecca Claire Murphy](https://gitlab.com/rcmurphy), aka Myrhea
- [Peter Pfeufer](https://gitlab.com/ppfeufer), aka Rounon Dax
%package -n python3-aa-blueprints
Summary: Blueprint Library plugin for Alliance Auth
Provides: python-aa-blueprints
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aa-blueprints
# AA Blueprints
This is an blueprints library app for [Alliance Auth](https://gitlab.com/allianceauth/allianceauth) (AA) that can be used to list blueprints for your corporation or alliance.






## Overview
### Features
- Lists all blueprints owned by corporation or alliance (configurable with permissions)
- Manage user requests for making copies of blueprints
>**Hint**
Blueprints sends Auth notifications to inform users about blueprint requests. If you like to get those as direct messages on Discord please consider also installing [Discord Notify](https://gitlab.com/ErikKalkoken/aa-discordnotify).
## Screenshots
### Library

#### View Blueprint

#### Create a Request

#### My Requests

#### Open Requests

#### Manage Blueprints

## Installation
### Requirements
AA Blueprints needs the app [django-eveuniverse](https://gitlab.com/ErikKalkoken/django-eveuniverse) to function. Please make sure it is installed before before continuing.
### Steps
#### Step 1 - Install the Package
Make sure you are in the virtual environment (venv) of your Alliance Auth installation. Then install the newest release from PyPI:
`pip install aa-blueprints`
#### Step 2 - Configure AA
- Add 'blueprints' to `INSTALLED_APPS` in `settings/local.py`.
- Add the following automated task definition:
```python
CELERYBEAT_SCHEDULE['blueprints_update_all_blueprints'] = {
'task': 'blueprints.tasks.update_all_blueprints',
'schedule': crontab(minute=0, hour='*/3'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_industry_jobs'] = {
'task': 'blueprints.tasks.update_all_industry_jobs',
'schedule': crontab(minute=0, hour='*'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_locations'] = {
'task': 'blueprints.tasks.update_all_locations',
'schedule': crontab(minute=0, hour='*/12'),
}
```
#### Step 3 - Finalize App installation
Run migrations & copy static files:
```bash
python manage.py migrate
python manage.py collectstatic
```
Restart your supervisor services for Auth
#### Step 4 - Update EVE Online API Application
Update the Eve Online API app used for authentication in your AA installation to include the following scopes:
- `esi-assets.read_assets.v1`
- `esi-assets.read_corporation_assets.v1`
- `esi-characters.read_blueprints.v1`
- `esi-corporations.read_blueprints.v1`
- `esi-industry.read_character_jobs.v1`
- `esi-industry.read_corporation_jobs.v1`
- `esi-universe.read_structures.v1`
#### Step 5 - Data import
Load EVE Online type data from ESI:
```bash
python manage.py blueprints_load_types
```
## Permissions
| ID | Description | Notes |
|----------------------------------|----------------------------------------------|--------------------------------------------------------------------------------|
| `basic_access` | Can access this app | |
| `request_blueprints` | Can request blueprints | |
| `manage_requests` | Can review and accept blueprint requests | |
| `add_personal_blueprint_owner` | Can add personal blueprint owners | |
| `add_corporate_blueprint_owner` | Can add corporate blueprint owners | :warning: Should only be given to directors or the CEO. |
| `view_alliance_blueprints` | Can view alliance's blueprints | |
| `view_industry_jobs` | Can view details about running industry jobs | :warning: This permission will let someone see _all_ industry job information. |
## Upgrading
See [UPGRADING.md](UPGRADING.md).
## Authors
The main authors (in alphabetical order):
- [Erik Kalkoken](https://gitlab.com/ErikKalkoken)
- [Rebecca Claire Murphy](https://gitlab.com/rcmurphy), aka Myrhea
- [Peter Pfeufer](https://gitlab.com/ppfeufer), aka Rounon Dax
%package help
Summary: Development documents and examples for aa-blueprints
Provides: python3-aa-blueprints-doc
%description help
# AA Blueprints
This is an blueprints library app for [Alliance Auth](https://gitlab.com/allianceauth/allianceauth) (AA) that can be used to list blueprints for your corporation or alliance.






## Overview
### Features
- Lists all blueprints owned by corporation or alliance (configurable with permissions)
- Manage user requests for making copies of blueprints
>**Hint**
Blueprints sends Auth notifications to inform users about blueprint requests. If you like to get those as direct messages on Discord please consider also installing [Discord Notify](https://gitlab.com/ErikKalkoken/aa-discordnotify).
## Screenshots
### Library

#### View Blueprint

#### Create a Request

#### My Requests

#### Open Requests

#### Manage Blueprints

## Installation
### Requirements
AA Blueprints needs the app [django-eveuniverse](https://gitlab.com/ErikKalkoken/django-eveuniverse) to function. Please make sure it is installed before before continuing.
### Steps
#### Step 1 - Install the Package
Make sure you are in the virtual environment (venv) of your Alliance Auth installation. Then install the newest release from PyPI:
`pip install aa-blueprints`
#### Step 2 - Configure AA
- Add 'blueprints' to `INSTALLED_APPS` in `settings/local.py`.
- Add the following automated task definition:
```python
CELERYBEAT_SCHEDULE['blueprints_update_all_blueprints'] = {
'task': 'blueprints.tasks.update_all_blueprints',
'schedule': crontab(minute=0, hour='*/3'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_industry_jobs'] = {
'task': 'blueprints.tasks.update_all_industry_jobs',
'schedule': crontab(minute=0, hour='*'),
}
CELERYBEAT_SCHEDULE['blueprints_update_all_locations'] = {
'task': 'blueprints.tasks.update_all_locations',
'schedule': crontab(minute=0, hour='*/12'),
}
```
#### Step 3 - Finalize App installation
Run migrations & copy static files:
```bash
python manage.py migrate
python manage.py collectstatic
```
Restart your supervisor services for Auth
#### Step 4 - Update EVE Online API Application
Update the Eve Online API app used for authentication in your AA installation to include the following scopes:
- `esi-assets.read_assets.v1`
- `esi-assets.read_corporation_assets.v1`
- `esi-characters.read_blueprints.v1`
- `esi-corporations.read_blueprints.v1`
- `esi-industry.read_character_jobs.v1`
- `esi-industry.read_corporation_jobs.v1`
- `esi-universe.read_structures.v1`
#### Step 5 - Data import
Load EVE Online type data from ESI:
```bash
python manage.py blueprints_load_types
```
## Permissions
| ID | Description | Notes |
|----------------------------------|----------------------------------------------|--------------------------------------------------------------------------------|
| `basic_access` | Can access this app | |
| `request_blueprints` | Can request blueprints | |
| `manage_requests` | Can review and accept blueprint requests | |
| `add_personal_blueprint_owner` | Can add personal blueprint owners | |
| `add_corporate_blueprint_owner` | Can add corporate blueprint owners | :warning: Should only be given to directors or the CEO. |
| `view_alliance_blueprints` | Can view alliance's blueprints | |
| `view_industry_jobs` | Can view details about running industry jobs | :warning: This permission will let someone see _all_ industry job information. |
## Upgrading
See [UPGRADING.md](UPGRADING.md).
## Authors
The main authors (in alphabetical order):
- [Erik Kalkoken](https://gitlab.com/ErikKalkoken)
- [Rebecca Claire Murphy](https://gitlab.com/rcmurphy), aka Myrhea
- [Peter Pfeufer](https://gitlab.com/ppfeufer), aka Rounon Dax
%prep
%autosetup -n aa-blueprints-1.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aa-blueprints -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.3.0-1
- Package Spec generated