%global _empty_manifest_terminate_build 0
Name:		python-piglet-templates
Version:	1.3.0
Release:	1
Summary:	Fast, robust HTML templating engine
License:	Apache
URL:		https://ollycope.com/software/piglet/latest/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fe/1f/5bb4b3b1902d3efd282e413f0e00dd46a6c3ab26e93d91cbe3b1414060eb/piglet-templates-1.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-pyparsing
Requires:	python3-attrs
Requires:	python3-astunparse
Requires:	python3-markupsafe

%description
piglet-templates is a text and HTML templating engine in the genshi/kajiki
templates family.
The Piglet template engine offers:
- Template inhertitance through <py:extends>/<py:block> (similar to Jinja2)
- Compiles templates to fast python byte code.
- HTML templating: templates produce well formed HTML. Template variables are
  autoescaped to protect against XSS attacks.
- Reusable template functions.
- Good i18n support.
- Clear tracebacks from exceptions raised in templates.
`Piglet Template Engine Documentation <https://ollycope.com/software/piglet/latest/>`_
\| `Repository <https://hg.sr.ht/~olly/piglet>`_
Example piglet template:
    <py:extends href="layout.html">
        <py:block name="content">
            <h1>This is the content block.</h1>
            <p>
                Hello $user.firstnames $user.lastname!
            </p>
            <p py:for="verse in poem">
                <py:for each="line in verse">$line<br/></py:for>
            </p>
        </py:block>
    </py:extends>
There's a text templating mode too:
    Hello $user.firstnames $user.lastname!
    {% for verse in poem %}
        {% for line in verse %}$line
        {% end %}
    {% end %}

%package -n python3-piglet-templates
Summary:	Fast, robust HTML templating engine
Provides:	python-piglet-templates
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-piglet-templates
piglet-templates is a text and HTML templating engine in the genshi/kajiki
templates family.
The Piglet template engine offers:
- Template inhertitance through <py:extends>/<py:block> (similar to Jinja2)
- Compiles templates to fast python byte code.
- HTML templating: templates produce well formed HTML. Template variables are
  autoescaped to protect against XSS attacks.
- Reusable template functions.
- Good i18n support.
- Clear tracebacks from exceptions raised in templates.
`Piglet Template Engine Documentation <https://ollycope.com/software/piglet/latest/>`_
\| `Repository <https://hg.sr.ht/~olly/piglet>`_
Example piglet template:
    <py:extends href="layout.html">
        <py:block name="content">
            <h1>This is the content block.</h1>
            <p>
                Hello $user.firstnames $user.lastname!
            </p>
            <p py:for="verse in poem">
                <py:for each="line in verse">$line<br/></py:for>
            </p>
        </py:block>
    </py:extends>
There's a text templating mode too:
    Hello $user.firstnames $user.lastname!
    {% for verse in poem %}
        {% for line in verse %}$line
        {% end %}
    {% end %}

%package help
Summary:	Development documents and examples for piglet-templates
Provides:	python3-piglet-templates-doc
%description help
piglet-templates is a text and HTML templating engine in the genshi/kajiki
templates family.
The Piglet template engine offers:
- Template inhertitance through <py:extends>/<py:block> (similar to Jinja2)
- Compiles templates to fast python byte code.
- HTML templating: templates produce well formed HTML. Template variables are
  autoescaped to protect against XSS attacks.
- Reusable template functions.
- Good i18n support.
- Clear tracebacks from exceptions raised in templates.
`Piglet Template Engine Documentation <https://ollycope.com/software/piglet/latest/>`_
\| `Repository <https://hg.sr.ht/~olly/piglet>`_
Example piglet template:
    <py:extends href="layout.html">
        <py:block name="content">
            <h1>This is the content block.</h1>
            <p>
                Hello $user.firstnames $user.lastname!
            </p>
            <p py:for="verse in poem">
                <py:for each="line in verse">$line<br/></py:for>
            </p>
        </py:block>
    </py:extends>
There's a text templating mode too:
    Hello $user.firstnames $user.lastname!
    {% for verse in poem %}
        {% for line in verse %}$line
        {% end %}
    {% end %}

%prep
%autosetup -n piglet-templates-1.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-piglet-templates -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
- Package Spec generated