%global _empty_manifest_terminate_build 0
Name:		python-equilibrator-api
Version:	0.4.7
Release:	1
Summary:	Calculation of standard thermodynamic potentials of biochemical reactions.
License:	MIT
URL:		https://gitlab.com/equilibrator/equilibrator-api/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/15/fc/4024b4ba267b0ca33fc065f080e15530bb55c6e029f26c3f63478b27b983/equilibrator-api-0.4.7.tar.gz
BuildArch:	noarch

Requires:	python3-pyparsing
Requires:	python3-slugify
Requires:	python3-equilibrator-cache
Requires:	python3-component-contribution
Requires:	python3-click
Requires:	python3-click-log
Requires:	python3-dateutil
Requires:	python3-requests
Requires:	python3-black
Requires:	python3-isort
Requires:	python3-safety
Requires:	python3-tox
Requires:	python3-twine
Requires:	python3-cobra
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-raises
Requires:	python3-pytest-allclose
Requires:	python3-sbtab

%description
# eQuilibrator - a thermodynamics calculator for biochemical reactions

[![PyPI version](https://badge.fury.io/py/equilibrator-api.svg)](https://badge.fury.io/py/equilibrator-api)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/equilibrator-api/badges/version.svg)](https://anaconda.org/conda-forge/equilibrator-api)
[![pipeline status](https://gitlab.com/elad.noor/equilibrator-api/badges/master/pipeline.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![coverage report](https://gitlab.com/elad.noor/equilibrator-api/badges/master/coverage.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![Join the chat at https://gitter.im/equilibrator-devs/equilibrator-api](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/equilibrator-devs/equilibrator-api?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![Documentation Status](https://readthedocs.org/projects/equilibrator/badge/?version=latest)](https://equilibrator.readthedocs.io/en/latest/?badge=latest)

## What is `equilibrator-api`?

`equilibrator-api` is a Python package for obtaining estimates of reactions Gibbs energies.
It is mainly meant for biologists/bioengineers with basic programming skills that
work on metabolism and want to easily add thermodynamic data to their models.

The documentation is browseable online at
[readthedocs](https://equilibrator.readthedocs.io/en/latest/index.html).

If your list of reactions is very short, we recommend trying our
website called [eQuilibrator](http://equilibrator.weizmann.ac.il/) before spending
the time necessary for learning how to use `equilibrator-api`.

The main advantages of `equilibrator-api` are:

* Batch mode: can be used for large reaction datasets (even more than 1000 reactions)
* Does not require a network connection (except during installation and initialization)
* Works with standard compound identifiers (such as ChEBI, KEGG, BiGG and MetaNetX) for more than 500,000 compounds

To access more advanced features, such as adding new compounds that are not
among the 500,000 currently in the MetaNetX database, try using our 
[equilibrator-assets](https://gitlab.com/equilibrator/equilibrator-assets)
package.

## Cite us

If you plan to use results from `equilibrator-api` in a scientific publication,
please cite our paper:

Noor E, Haraldsdóttir HS, Milo R, Fleming RMT (2013)
[Consistent Estimation of Gibbs Energy Using Component Contributions](http://journals.plos.org/ploscompbiol/article?id=10.1371/journal.pcbi.1003098),
PLoS Comput Biol 9:e1003098, DOI: 10.1371/journal.pcbi.1003098

## A very simple example

Note that creating a `ComponentContribution` object for the first time after
installation, starts an initialization step which downloads ~1.5 GBytes of data
to your computer. It can take more than an hour (depending on the connection speed).
Note that the initialization might not work inside a Jupyter notebook environment - 
in that case you should try running it in a standard python shell first and then
run the Jupyter notebook.

```python
from equilibrator_api import ComponentContribution
cc = ComponentContribution()
rxn = cc.parse_reaction_formula("kegg:C00002 + kegg:C00001 = kegg:C00008 + kegg:C00009")
print(f"ΔG'0 = {cc.standard_dg_prime(rxn)}")
```


%package -n python3-equilibrator-api
Summary:	Calculation of standard thermodynamic potentials of biochemical reactions.
Provides:	python-equilibrator-api
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-equilibrator-api
# eQuilibrator - a thermodynamics calculator for biochemical reactions

[![PyPI version](https://badge.fury.io/py/equilibrator-api.svg)](https://badge.fury.io/py/equilibrator-api)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/equilibrator-api/badges/version.svg)](https://anaconda.org/conda-forge/equilibrator-api)
[![pipeline status](https://gitlab.com/elad.noor/equilibrator-api/badges/master/pipeline.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![coverage report](https://gitlab.com/elad.noor/equilibrator-api/badges/master/coverage.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![Join the chat at https://gitter.im/equilibrator-devs/equilibrator-api](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/equilibrator-devs/equilibrator-api?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![Documentation Status](https://readthedocs.org/projects/equilibrator/badge/?version=latest)](https://equilibrator.readthedocs.io/en/latest/?badge=latest)

## What is `equilibrator-api`?

`equilibrator-api` is a Python package for obtaining estimates of reactions Gibbs energies.
It is mainly meant for biologists/bioengineers with basic programming skills that
work on metabolism and want to easily add thermodynamic data to their models.

The documentation is browseable online at
[readthedocs](https://equilibrator.readthedocs.io/en/latest/index.html).

If your list of reactions is very short, we recommend trying our
website called [eQuilibrator](http://equilibrator.weizmann.ac.il/) before spending
the time necessary for learning how to use `equilibrator-api`.

The main advantages of `equilibrator-api` are:

* Batch mode: can be used for large reaction datasets (even more than 1000 reactions)
* Does not require a network connection (except during installation and initialization)
* Works with standard compound identifiers (such as ChEBI, KEGG, BiGG and MetaNetX) for more than 500,000 compounds

To access more advanced features, such as adding new compounds that are not
among the 500,000 currently in the MetaNetX database, try using our 
[equilibrator-assets](https://gitlab.com/equilibrator/equilibrator-assets)
package.

## Cite us

If you plan to use results from `equilibrator-api` in a scientific publication,
please cite our paper:

Noor E, Haraldsdóttir HS, Milo R, Fleming RMT (2013)
[Consistent Estimation of Gibbs Energy Using Component Contributions](http://journals.plos.org/ploscompbiol/article?id=10.1371/journal.pcbi.1003098),
PLoS Comput Biol 9:e1003098, DOI: 10.1371/journal.pcbi.1003098

## A very simple example

Note that creating a `ComponentContribution` object for the first time after
installation, starts an initialization step which downloads ~1.5 GBytes of data
to your computer. It can take more than an hour (depending on the connection speed).
Note that the initialization might not work inside a Jupyter notebook environment - 
in that case you should try running it in a standard python shell first and then
run the Jupyter notebook.

```python
from equilibrator_api import ComponentContribution
cc = ComponentContribution()
rxn = cc.parse_reaction_formula("kegg:C00002 + kegg:C00001 = kegg:C00008 + kegg:C00009")
print(f"ΔG'0 = {cc.standard_dg_prime(rxn)}")
```


%package help
Summary:	Development documents and examples for equilibrator-api
Provides:	python3-equilibrator-api-doc
%description help
# eQuilibrator - a thermodynamics calculator for biochemical reactions

[![PyPI version](https://badge.fury.io/py/equilibrator-api.svg)](https://badge.fury.io/py/equilibrator-api)
[![Anaconda-Server Badge](https://anaconda.org/conda-forge/equilibrator-api/badges/version.svg)](https://anaconda.org/conda-forge/equilibrator-api)
[![pipeline status](https://gitlab.com/elad.noor/equilibrator-api/badges/master/pipeline.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![coverage report](https://gitlab.com/elad.noor/equilibrator-api/badges/master/coverage.svg)](https://gitlab.com/elad.noor/equilibrator-api/commits/master)
[![Join the chat at https://gitter.im/equilibrator-devs/equilibrator-api](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/equilibrator-devs/equilibrator-api?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![Documentation Status](https://readthedocs.org/projects/equilibrator/badge/?version=latest)](https://equilibrator.readthedocs.io/en/latest/?badge=latest)

## What is `equilibrator-api`?

`equilibrator-api` is a Python package for obtaining estimates of reactions Gibbs energies.
It is mainly meant for biologists/bioengineers with basic programming skills that
work on metabolism and want to easily add thermodynamic data to their models.

The documentation is browseable online at
[readthedocs](https://equilibrator.readthedocs.io/en/latest/index.html).

If your list of reactions is very short, we recommend trying our
website called [eQuilibrator](http://equilibrator.weizmann.ac.il/) before spending
the time necessary for learning how to use `equilibrator-api`.

The main advantages of `equilibrator-api` are:

* Batch mode: can be used for large reaction datasets (even more than 1000 reactions)
* Does not require a network connection (except during installation and initialization)
* Works with standard compound identifiers (such as ChEBI, KEGG, BiGG and MetaNetX) for more than 500,000 compounds

To access more advanced features, such as adding new compounds that are not
among the 500,000 currently in the MetaNetX database, try using our 
[equilibrator-assets](https://gitlab.com/equilibrator/equilibrator-assets)
package.

## Cite us

If you plan to use results from `equilibrator-api` in a scientific publication,
please cite our paper:

Noor E, Haraldsdóttir HS, Milo R, Fleming RMT (2013)
[Consistent Estimation of Gibbs Energy Using Component Contributions](http://journals.plos.org/ploscompbiol/article?id=10.1371/journal.pcbi.1003098),
PLoS Comput Biol 9:e1003098, DOI: 10.1371/journal.pcbi.1003098

## A very simple example

Note that creating a `ComponentContribution` object for the first time after
installation, starts an initialization step which downloads ~1.5 GBytes of data
to your computer. It can take more than an hour (depending on the connection speed).
Note that the initialization might not work inside a Jupyter notebook environment - 
in that case you should try running it in a standard python shell first and then
run the Jupyter notebook.

```python
from equilibrator_api import ComponentContribution
cc = ComponentContribution()
rxn = cc.parse_reaction_formula("kegg:C00002 + kegg:C00001 = kegg:C00008 + kegg:C00009")
print(f"ΔG'0 = {cc.standard_dg_prime(rxn)}")
```


%prep
%autosetup -n equilibrator-api-0.4.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-equilibrator-api -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.7-1
- Package Spec generated