%global _empty_manifest_terminate_build 0
Name: python-Mopidy-Muse
Version: 0.0.27
Release: 1
Summary: Mopidy interface with snapcast support
License: Apache License, Version 2.0
URL: https://github.com/cristianpb/muse
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/13/4d63ac8b0a9e66aea4ad775454a65ad8ae4b2364b5e430965f446ef88655/Mopidy-Muse-0.0.27.tar.gz
BuildArch: noarch
Requires: python3-Mopidy
Requires: python3-Pykka
Requires: python3-setuptools
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-flake8-import-order
Requires: python3-isort[pyproject]
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-twine
Requires: python3-wheel
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-flake8-import-order
Requires: python3-isort[pyproject]
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest
Requires: python3-pytest-cov
%description
# Muse
  [](https://actions-badge.atrox.dev/cristianpb/muse/goto?ref=master) 
A mopidy player with snapcast support
## Features
* Support for snapcast volume control
* Responsive design based in bulma framework
* Modify tracklists using drag and drop motions
* Create and modify playlists
* Reactive search for tracklists in different sources
* No user tracking (No Google Analytics)
* Created using state of the art web technologies:
* Svelte framework for small package size
* Sapper for multiple pages and server side rendering
* Github Actions CI/CD workflow for build and publish
Checkout a detailled description at [this blog post](https://cristianpb.github.io/blog/mopidy-muse)
## Installation
### Python
Install by running:
```bash
python3 -m pip install Mopidy-Muse
```
Before starting Mopidy, you must add configuration for Mopidy-Muse to your Mopidy configuration file:
```conf
[muse]
enabled = true
# the following are optional values
mopidy_host = localhost
mopidy_port = 6680
mopidy_ssl = false
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false
```
### Docker installation
Using docker compose:
```bash
make start
```
Using docker run command:
```bash
make mopidy-docker
```
## Project resources
* [Source code](https://github.com/cristianpb/muse)
* [Issue tracker](https://github.com/cristianpb/muse/issues)
%package -n python3-Mopidy-Muse
Summary: Mopidy interface with snapcast support
Provides: python-Mopidy-Muse
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Mopidy-Muse
# Muse
  [](https://actions-badge.atrox.dev/cristianpb/muse/goto?ref=master) 
A mopidy player with snapcast support
## Features
* Support for snapcast volume control
* Responsive design based in bulma framework
* Modify tracklists using drag and drop motions
* Create and modify playlists
* Reactive search for tracklists in different sources
* No user tracking (No Google Analytics)
* Created using state of the art web technologies:
* Svelte framework for small package size
* Sapper for multiple pages and server side rendering
* Github Actions CI/CD workflow for build and publish
Checkout a detailled description at [this blog post](https://cristianpb.github.io/blog/mopidy-muse)
## Installation
### Python
Install by running:
```bash
python3 -m pip install Mopidy-Muse
```
Before starting Mopidy, you must add configuration for Mopidy-Muse to your Mopidy configuration file:
```conf
[muse]
enabled = true
# the following are optional values
mopidy_host = localhost
mopidy_port = 6680
mopidy_ssl = false
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false
```
### Docker installation
Using docker compose:
```bash
make start
```
Using docker run command:
```bash
make mopidy-docker
```
## Project resources
* [Source code](https://github.com/cristianpb/muse)
* [Issue tracker](https://github.com/cristianpb/muse/issues)
%package help
Summary: Development documents and examples for Mopidy-Muse
Provides: python3-Mopidy-Muse-doc
%description help
# Muse
  [](https://actions-badge.atrox.dev/cristianpb/muse/goto?ref=master) 
A mopidy player with snapcast support
## Features
* Support for snapcast volume control
* Responsive design based in bulma framework
* Modify tracklists using drag and drop motions
* Create and modify playlists
* Reactive search for tracklists in different sources
* No user tracking (No Google Analytics)
* Created using state of the art web technologies:
* Svelte framework for small package size
* Sapper for multiple pages and server side rendering
* Github Actions CI/CD workflow for build and publish
Checkout a detailled description at [this blog post](https://cristianpb.github.io/blog/mopidy-muse)
## Installation
### Python
Install by running:
```bash
python3 -m pip install Mopidy-Muse
```
Before starting Mopidy, you must add configuration for Mopidy-Muse to your Mopidy configuration file:
```conf
[muse]
enabled = true
# the following are optional values
mopidy_host = localhost
mopidy_port = 6680
mopidy_ssl = false
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false
```
### Docker installation
Using docker compose:
```bash
make start
```
Using docker run command:
```bash
make mopidy-docker
```
## Project resources
* [Source code](https://github.com/cristianpb/muse)
* [Issue tracker](https://github.com/cristianpb/muse/issues)
%prep
%autosetup -n Mopidy-Muse-0.0.27
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Mopidy-Muse -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.0.27-1
- Package Spec generated