%global _empty_manifest_terminate_build 0
Name: python-medgpt
Version: 0.3.3
Release: 1
Summary: Temporal modeling of patients and diseases
License: MIT License
URL: https://github.com/w-is-h/medgpt
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/fb/96e10f7334e0ba65e8fb1bc5229eff321a2ca4051bf0ec582bce1c1e0bfb/medgpt-0.3.3.tar.gz
BuildArch: noarch
Requires: python3-datasets
Requires: python3-ray
Requires: python3-wandb
Requires: python3-x-transformers
Requires: python3-ecco
Requires: python3-transformers
%description
# MedGPT: Medical Concept Forecasting from Clinical Narratives
## Installation
`pip install --upgrade medgpt`
## !!! WORK IN PROGRESS !!!
%package -n python3-medgpt
Summary: Temporal modeling of patients and diseases
Provides: python-medgpt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-medgpt
# MedGPT: Medical Concept Forecasting from Clinical Narratives
## Installation
`pip install --upgrade medgpt`
## !!! WORK IN PROGRESS !!!
%package help
Summary: Development documents and examples for medgpt
Provides: python3-medgpt-doc
%description help
# MedGPT: Medical Concept Forecasting from Clinical Narratives
## Installation
`pip install --upgrade medgpt`
## !!! WORK IN PROGRESS !!!
%prep
%autosetup -n medgpt-0.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-medgpt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.3.3-1
- Package Spec generated