%global _empty_manifest_terminate_build 0
Name: python-akimous
Version: 0.9.0
Release: 1
Summary: An intelligent Python IDE
License: BSD-3-Clause
URL: https://akimous.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/d3/807d91e6fa847706b6818f5e6e1c4150c2044902668802f01b12855dfc59/akimous-0.9.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-jedi
Requires: python3-sphinx
Requires: python3-watchdog
Requires: python3-logzero
Requires: python3-websockets
Requires: python3-xgboost
Requires: python3-numpydoc
Requires: python3-fuzzywuzzy
Requires: python3-levenshtein
Requires: python3-msgpack
Requires: python3-wordsegment
Requires: python3-pylint
Requires: python3-pyflakes
Requires: python3-yapf
Requires: python3-pathspec
Requires: python3-cachetools
Requires: python3-appdirs
Requires: python3-ptyprocess
Requires: python3-jupyter_client
Requires: python3-ipykernel
Requires: python3-toml
Requires: python3-Send2Trash
Requires: python3-gitpython
%description
# Akimous
[![PyPI version](https://badge.fury.io/py/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![PyPI pyversions](https://img.shields.io/pypi/pyversions/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![CircleCI](https://circleci.com/gh/akimous/akimous/tree/master.svg?style=svg)](https://circleci.com/gh/akimous/akimous/tree/master)
Akimous is a Python IDE with unique features boosting developers' productivity.
### Features
* Machine-learning-assisted/NLP-assisted context-aware auto completion
* Beautifully rendered function documentation
* Layered keyboard control (a more intuitive key binding than vim and Emacs)
* Real-time code formatter
* Interactive console (integration with IPython kernel)
For more information and documentation, visit the official website.
## Installation
### Prerequisite
* Python 3.7 or 3.8 (with pip)
* Git (for version control integration)
* C/C++ compiler (may be required by some dependencies during installation)
* A modern browser
### Installing From PyPI
The recommended way for installing Akimous is through PyPI.
```sh
pip install -U akimous
```
### Starting Application
Start it in the terminal. The browser should be automatically opened.
```sh
akimous
```
* To see available arguments, do `akimous --help`.
### Using Docker Image
If you have difficulty installing, or you are running in a cloud environment, try the prebuilt docker image.
```sh
docker run --mount type=bind,source=$HOME,target=/home/user -p 127.0.0.1:3179:3179 -it red8012/akimous akimous
```
## Commands
Start the app by typing in the terminal (the browser will automatically open if available):
```sh
akimous
```
#### Options
* `--help`: show help message and exit.
* `--host HOST`: specify the host for Akimous server to listen on. (default to 0.0.0.0 if inside docker, otherwise 127.0.0.1)
* `--port PORT`: The port number for Akimous server to listen on. (default=3179)
* `--no-browser`: Do not open the IDE in a browser after startup.
* `--verbose`: Print extra debug messages.
## Development
Make sure you have recent version of the following build dependencies installed.
* Node (12+)
* Python (3.7+)
* [Poetry](https://poetry.eustace.io)
* [Yarn](https://yarnpkg.com/)
* Make
* [Zopfli](https://github.com/google/zopfli)
* [Parallel](https://www.gnu.org/software/parallel/)
Run the following commands according to your need.
```sh
make # build everything
make test # run tests
make lint # run linters
make install # (re)install the package
```
Running `make` will install all Python and Javascript dependencies listed in `pyproject.toml` and `ui/package.json` automatically.
## Contributing
This program is at pre-alpha stage. Please do report issues if you run into some problems. Contributions of any kind are welcome, including feature requests or pull requests (can be as small as correcting spelling errors) .
## License
[BSD-3-Clause](LICENSE)
## Links
* [Official website](https://akimous.com)
* [PyPI](https://pypi.org/project/akimous/)
* [Docker Hub](https://hub.docker.com/r/red8012/akimous)
%package -n python3-akimous
Summary: An intelligent Python IDE
Provides: python-akimous
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-akimous
# Akimous
[![PyPI version](https://badge.fury.io/py/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![PyPI pyversions](https://img.shields.io/pypi/pyversions/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![CircleCI](https://circleci.com/gh/akimous/akimous/tree/master.svg?style=svg)](https://circleci.com/gh/akimous/akimous/tree/master)
Akimous is a Python IDE with unique features boosting developers' productivity.
### Features
* Machine-learning-assisted/NLP-assisted context-aware auto completion
* Beautifully rendered function documentation
* Layered keyboard control (a more intuitive key binding than vim and Emacs)
* Real-time code formatter
* Interactive console (integration with IPython kernel)
For more information and documentation, visit the official website.
## Installation
### Prerequisite
* Python 3.7 or 3.8 (with pip)
* Git (for version control integration)
* C/C++ compiler (may be required by some dependencies during installation)
* A modern browser
### Installing From PyPI
The recommended way for installing Akimous is through PyPI.
```sh
pip install -U akimous
```
### Starting Application
Start it in the terminal. The browser should be automatically opened.
```sh
akimous
```
* To see available arguments, do `akimous --help`.
### Using Docker Image
If you have difficulty installing, or you are running in a cloud environment, try the prebuilt docker image.
```sh
docker run --mount type=bind,source=$HOME,target=/home/user -p 127.0.0.1:3179:3179 -it red8012/akimous akimous
```
## Commands
Start the app by typing in the terminal (the browser will automatically open if available):
```sh
akimous
```
#### Options
* `--help`: show help message and exit.
* `--host HOST`: specify the host for Akimous server to listen on. (default to 0.0.0.0 if inside docker, otherwise 127.0.0.1)
* `--port PORT`: The port number for Akimous server to listen on. (default=3179)
* `--no-browser`: Do not open the IDE in a browser after startup.
* `--verbose`: Print extra debug messages.
## Development
Make sure you have recent version of the following build dependencies installed.
* Node (12+)
* Python (3.7+)
* [Poetry](https://poetry.eustace.io)
* [Yarn](https://yarnpkg.com/)
* Make
* [Zopfli](https://github.com/google/zopfli)
* [Parallel](https://www.gnu.org/software/parallel/)
Run the following commands according to your need.
```sh
make # build everything
make test # run tests
make lint # run linters
make install # (re)install the package
```
Running `make` will install all Python and Javascript dependencies listed in `pyproject.toml` and `ui/package.json` automatically.
## Contributing
This program is at pre-alpha stage. Please do report issues if you run into some problems. Contributions of any kind are welcome, including feature requests or pull requests (can be as small as correcting spelling errors) .
## License
[BSD-3-Clause](LICENSE)
## Links
* [Official website](https://akimous.com)
* [PyPI](https://pypi.org/project/akimous/)
* [Docker Hub](https://hub.docker.com/r/red8012/akimous)
%package help
Summary: Development documents and examples for akimous
Provides: python3-akimous-doc
%description help
# Akimous
[![PyPI version](https://badge.fury.io/py/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![PyPI pyversions](https://img.shields.io/pypi/pyversions/akimous.svg)](https://pypi.python.org/pypi/akimous/) [![CircleCI](https://circleci.com/gh/akimous/akimous/tree/master.svg?style=svg)](https://circleci.com/gh/akimous/akimous/tree/master)
Akimous is a Python IDE with unique features boosting developers' productivity.
### Features
* Machine-learning-assisted/NLP-assisted context-aware auto completion
* Beautifully rendered function documentation
* Layered keyboard control (a more intuitive key binding than vim and Emacs)
* Real-time code formatter
* Interactive console (integration with IPython kernel)
For more information and documentation, visit the official website.
## Installation
### Prerequisite
* Python 3.7 or 3.8 (with pip)
* Git (for version control integration)
* C/C++ compiler (may be required by some dependencies during installation)
* A modern browser
### Installing From PyPI
The recommended way for installing Akimous is through PyPI.
```sh
pip install -U akimous
```
### Starting Application
Start it in the terminal. The browser should be automatically opened.
```sh
akimous
```
* To see available arguments, do `akimous --help`.
### Using Docker Image
If you have difficulty installing, or you are running in a cloud environment, try the prebuilt docker image.
```sh
docker run --mount type=bind,source=$HOME,target=/home/user -p 127.0.0.1:3179:3179 -it red8012/akimous akimous
```
## Commands
Start the app by typing in the terminal (the browser will automatically open if available):
```sh
akimous
```
#### Options
* `--help`: show help message and exit.
* `--host HOST`: specify the host for Akimous server to listen on. (default to 0.0.0.0 if inside docker, otherwise 127.0.0.1)
* `--port PORT`: The port number for Akimous server to listen on. (default=3179)
* `--no-browser`: Do not open the IDE in a browser after startup.
* `--verbose`: Print extra debug messages.
## Development
Make sure you have recent version of the following build dependencies installed.
* Node (12+)
* Python (3.7+)
* [Poetry](https://poetry.eustace.io)
* [Yarn](https://yarnpkg.com/)
* Make
* [Zopfli](https://github.com/google/zopfli)
* [Parallel](https://www.gnu.org/software/parallel/)
Run the following commands according to your need.
```sh
make # build everything
make test # run tests
make lint # run linters
make install # (re)install the package
```
Running `make` will install all Python and Javascript dependencies listed in `pyproject.toml` and `ui/package.json` automatically.
## Contributing
This program is at pre-alpha stage. Please do report issues if you run into some problems. Contributions of any kind are welcome, including feature requests or pull requests (can be as small as correcting spelling errors) .
## License
[BSD-3-Clause](LICENSE)
## Links
* [Official website](https://akimous.com)
* [PyPI](https://pypi.org/project/akimous/)
* [Docker Hub](https://hub.docker.com/r/red8012/akimous)
%prep
%autosetup -n akimous-0.9.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-akimous -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.9.0-1
- Package Spec generated