%global _empty_manifest_terminate_build 0
Name: python-fava
Version: 1.24.4
Release: 1
Summary: Web interface for the accounting tool Beancount.
License: MIT
URL: https://beancount.github.io/fava/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/06/06/945342d5c5c79f48f0fa61e6d169c9c86613ee12f7090322cb2392847c44/fava-1.24.4.tar.gz
BuildArch: noarch
Requires: python3-Babel
Requires: python3-Flask-Babel
Requires: python3-Flask
Requires: python3-Jinja2
Requires: python3-Werkzeug
Requires: python3-beancount
Requires: python3-cheroot
Requires: python3-click
Requires: python3-markdown2
Requires: python3-ply
Requires: python3-simplejson
Requires: python3-importlib-metadata
Requires: python3-pyexcel
Requires: python3-pyexcel-ods3
Requires: python3-pyexcel-xls
Requires: python3-pyexcel-xlsx
%description
.. image:: https://badges.gitter.im/beancount/fava.svg
:alt: Join the chat at https://gitter.im/beancount/fava
:target: https://gitter.im/beancount/fava
.. image:: https://img.shields.io/pypi/l/fava.svg
:target: https://pypi.python.org/pypi/fava
.. image:: https://img.shields.io/pypi/v/fava.svg
:target: https://pypi.python.org/pypi/fava
Fava is a web interface for the double-entry bookkeeping software `Beancount
`__ with a focus on features and usability.
Check out the online `demo `__ and learn more
about Fava on the `website `__.
The `Getting Started
`__ guide details the installation
and how to get started with Beancount. If you are already familiar with
Beancount, you can get started with Fava::
pip3 install fava
fava ledger.beancount
and visit the web interface at `http://localhost:5000
`__.
If you want to hack on Fava or run a development version, see the
`Development `__ page on the
website for details. Contributions are very welcome!
.. image:: https://i.imgbox.com/rfb9I7Zw.png
:alt: Fava Screenshot
:width: 100%
:align: center
:target: https://fava.pythonanywhere.com
%package -n python3-fava
Summary: Web interface for the accounting tool Beancount.
Provides: python-fava
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fava
.. image:: https://badges.gitter.im/beancount/fava.svg
:alt: Join the chat at https://gitter.im/beancount/fava
:target: https://gitter.im/beancount/fava
.. image:: https://img.shields.io/pypi/l/fava.svg
:target: https://pypi.python.org/pypi/fava
.. image:: https://img.shields.io/pypi/v/fava.svg
:target: https://pypi.python.org/pypi/fava
Fava is a web interface for the double-entry bookkeeping software `Beancount
`__ with a focus on features and usability.
Check out the online `demo `__ and learn more
about Fava on the `website `__.
The `Getting Started
`__ guide details the installation
and how to get started with Beancount. If you are already familiar with
Beancount, you can get started with Fava::
pip3 install fava
fava ledger.beancount
and visit the web interface at `http://localhost:5000
`__.
If you want to hack on Fava or run a development version, see the
`Development `__ page on the
website for details. Contributions are very welcome!
.. image:: https://i.imgbox.com/rfb9I7Zw.png
:alt: Fava Screenshot
:width: 100%
:align: center
:target: https://fava.pythonanywhere.com
%package help
Summary: Development documents and examples for fava
Provides: python3-fava-doc
%description help
.. image:: https://badges.gitter.im/beancount/fava.svg
:alt: Join the chat at https://gitter.im/beancount/fava
:target: https://gitter.im/beancount/fava
.. image:: https://img.shields.io/pypi/l/fava.svg
:target: https://pypi.python.org/pypi/fava
.. image:: https://img.shields.io/pypi/v/fava.svg
:target: https://pypi.python.org/pypi/fava
Fava is a web interface for the double-entry bookkeeping software `Beancount
`__ with a focus on features and usability.
Check out the online `demo `__ and learn more
about Fava on the `website `__.
The `Getting Started
`__ guide details the installation
and how to get started with Beancount. If you are already familiar with
Beancount, you can get started with Fava::
pip3 install fava
fava ledger.beancount
and visit the web interface at `http://localhost:5000
`__.
If you want to hack on Fava or run a development version, see the
`Development `__ page on the
website for details. Contributions are very welcome!
.. image:: https://i.imgbox.com/rfb9I7Zw.png
:alt: Fava Screenshot
:width: 100%
:align: center
:target: https://fava.pythonanywhere.com
%prep
%autosetup -n fava-1.24.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fava -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.24.4-1
- Package Spec generated