%global _empty_manifest_terminate_build 0
Name:		python-trytond-stock-package-shipping-ups
Version:	6.8.0
Release:	1
Summary:	UPS connector for the Tryton application platform
License:	GPL-3
URL:		http://www.tryton.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d3/95/767bfc4adcde18e8196c2f1b16633a28ad36fb7a8a55f2e6aabe57221cd3/trytond_stock_package_shipping_ups-6.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-trytond-party
Requires:	python3-trytond-product
Requires:	python3-trytond-stock
Requires:	python3-trytond-stock-shipment-measurements
Requires:	python3-trytond-stock-package
Requires:	python3-trytond-stock-package-shipping
Requires:	python3-trytond
Requires:	python3-proteus
Requires:	python3-trytond-sale
Requires:	python3-trytond-sale-shipment-cost

%description
Stock Package Shipping UPS Module
#################################

The Stock Package Shipping UPS module allows you to generate the UPS labels per
package using the UPS webservices.

The credential for the webservice is specified by the following fields:

UPS Carrier Credential
**********************

This model allows to define the credential used to connect the UPS API.
The credentials used to connect to the UPS API will be automatically retrieved
based on the company of the Shipment.

- *Company*: The company for which those credentials are valid
- *User ID*: The User ID provided by UPS.
- *Password*: The Password used to access the MyUPS Portal.
- *Account Number*: The account number UPS assigned to you when you requested the
  API credentials (also known as the Shipper Number).
- *License*: The License number UPS assigned to you when you requested the API
  credentials
- *Server*: Are those credentials used for accessing the Testing or the
  Production server of UPS.
- *Use Metric*: Use Metric units when communicating with the UPS webservice.

Carrier
*******

The Carrier model is extended with the following fields:

- *Service Type*: The UPS service type requested
- *Label Image Format*: The Image Format used for the label sent by UPS
- *Label Image Height*: The Height of the label sent by UPS.

Package Type
************

The Package Type model is extended with the following field:

- *UPS Code*: The UPS Code of the package.


%package -n python3-trytond-stock-package-shipping-ups
Summary:	UPS connector for the Tryton application platform
Provides:	python-trytond-stock-package-shipping-ups
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-trytond-stock-package-shipping-ups
Stock Package Shipping UPS Module
#################################

The Stock Package Shipping UPS module allows you to generate the UPS labels per
package using the UPS webservices.

The credential for the webservice is specified by the following fields:

UPS Carrier Credential
**********************

This model allows to define the credential used to connect the UPS API.
The credentials used to connect to the UPS API will be automatically retrieved
based on the company of the Shipment.

- *Company*: The company for which those credentials are valid
- *User ID*: The User ID provided by UPS.
- *Password*: The Password used to access the MyUPS Portal.
- *Account Number*: The account number UPS assigned to you when you requested the
  API credentials (also known as the Shipper Number).
- *License*: The License number UPS assigned to you when you requested the API
  credentials
- *Server*: Are those credentials used for accessing the Testing or the
  Production server of UPS.
- *Use Metric*: Use Metric units when communicating with the UPS webservice.

Carrier
*******

The Carrier model is extended with the following fields:

- *Service Type*: The UPS service type requested
- *Label Image Format*: The Image Format used for the label sent by UPS
- *Label Image Height*: The Height of the label sent by UPS.

Package Type
************

The Package Type model is extended with the following field:

- *UPS Code*: The UPS Code of the package.


%package help
Summary:	Development documents and examples for trytond-stock-package-shipping-ups
Provides:	python3-trytond-stock-package-shipping-ups-doc
%description help
Stock Package Shipping UPS Module
#################################

The Stock Package Shipping UPS module allows you to generate the UPS labels per
package using the UPS webservices.

The credential for the webservice is specified by the following fields:

UPS Carrier Credential
**********************

This model allows to define the credential used to connect the UPS API.
The credentials used to connect to the UPS API will be automatically retrieved
based on the company of the Shipment.

- *Company*: The company for which those credentials are valid
- *User ID*: The User ID provided by UPS.
- *Password*: The Password used to access the MyUPS Portal.
- *Account Number*: The account number UPS assigned to you when you requested the
  API credentials (also known as the Shipper Number).
- *License*: The License number UPS assigned to you when you requested the API
  credentials
- *Server*: Are those credentials used for accessing the Testing or the
  Production server of UPS.
- *Use Metric*: Use Metric units when communicating with the UPS webservice.

Carrier
*******

The Carrier model is extended with the following fields:

- *Service Type*: The UPS service type requested
- *Label Image Format*: The Image Format used for the label sent by UPS
- *Label Image Height*: The Height of the label sent by UPS.

Package Type
************

The Package Type model is extended with the following field:

- *UPS Code*: The UPS Code of the package.


%prep
%autosetup -n trytond-stock-package-shipping-ups-6.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-trytond-stock-package-shipping-ups -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 6.8.0-1
- Package Spec generated