%global _empty_manifest_terminate_build 0
Name:		python-views-transformation-library
Version:	2.7.0
Release:	1
Summary:	A package containing data transformation functions used by the ViEWS team
License:	CC-BY-NC
URL:		https://www.github.com/prio-data/views_transformation_library
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a2/84/c33fb06acaceb9aad46edd21eee8a8cda0cefceff9e4bb10a61f0d1b87df/views_transformation_library-2.7.0.tar.gz
BuildArch:	noarch

Requires:	python3-ingester3
Requires:	python3-pandas
Requires:	python3-scikit_learn
Requires:	python3-scipy
Requires:	python3-stepshift
Requires:	python3-xarray

%description

# ViEWS Transformation Library

This package contains transforms made available in ViEWS cloud.  The transforms
are all locally available, and do not depend on remote resources or
credentials.

## Contributing: 

There is an urgent need to fill this library with transforms.
Transforms we need, that are not implemented, are listed under issues.
Please follow the guidelines for contributing outlined in the [CONTRIBUTING.md](CONTRIBUTING.md) document.

## Usage:

```
pip install views-transformation-library
```

```
from views_transformation_library.timelag import timelag
import viewser

ged_best_ns = viewser.get_variable("priogrid_month","priogrid_month.ged_best_ns",2010,2020)
lagged_data = timelag(ged_best_ns,10)

lagged_from_api = viewser.get_variable("priogrid_month","ged_best_ns",2010,2020,transforms:[
   {"type":"tlag","args":[10]}
])

assert lagged_from_api == lagged_data
```

## API:

Each transform function operates on a pandas dataframe.

## Funding

The contents of this repository is the outcome of projects that have received funding from the European Research Council (ERC) under the European Union’s Horizon 2020 research and innovation programme (Grant agreement No. 694640, *ViEWS*) and Horizon Europe (Grant agreement No. 101055176, *ANTICIPATE*; and No. 101069312, *ViEWS* (ERC-2022-POC1)), Riksbankens Jubileumsfond (Grant agreement No. M21-0002, *Societies at Risk*), Uppsala University, Peace Research Institute Oslo, the United Nations Economic and Social Commission for Western Asia (*ViEWS-ESCWA*), the United Kingdom Foreign, Commonwealth & Development Office (GSRA – *Forecasting Fatalities in Armed Conflict*), the Swedish Research Council (*DEMSCORE*), the Swedish Foundation for Strategic Environmental Research (*MISTRA Geopolitics*), the Norwegian MFA (*Conflict Trends* QZA-18/0227), and the United Nations High Commissioner for Refugees (*the Sahel Predictive Analytics project*).



%package -n python3-views-transformation-library
Summary:	A package containing data transformation functions used by the ViEWS team
Provides:	python-views-transformation-library
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-views-transformation-library

# ViEWS Transformation Library

This package contains transforms made available in ViEWS cloud.  The transforms
are all locally available, and do not depend on remote resources or
credentials.

## Contributing: 

There is an urgent need to fill this library with transforms.
Transforms we need, that are not implemented, are listed under issues.
Please follow the guidelines for contributing outlined in the [CONTRIBUTING.md](CONTRIBUTING.md) document.

## Usage:

```
pip install views-transformation-library
```

```
from views_transformation_library.timelag import timelag
import viewser

ged_best_ns = viewser.get_variable("priogrid_month","priogrid_month.ged_best_ns",2010,2020)
lagged_data = timelag(ged_best_ns,10)

lagged_from_api = viewser.get_variable("priogrid_month","ged_best_ns",2010,2020,transforms:[
   {"type":"tlag","args":[10]}
])

assert lagged_from_api == lagged_data
```

## API:

Each transform function operates on a pandas dataframe.

## Funding

The contents of this repository is the outcome of projects that have received funding from the European Research Council (ERC) under the European Union’s Horizon 2020 research and innovation programme (Grant agreement No. 694640, *ViEWS*) and Horizon Europe (Grant agreement No. 101055176, *ANTICIPATE*; and No. 101069312, *ViEWS* (ERC-2022-POC1)), Riksbankens Jubileumsfond (Grant agreement No. M21-0002, *Societies at Risk*), Uppsala University, Peace Research Institute Oslo, the United Nations Economic and Social Commission for Western Asia (*ViEWS-ESCWA*), the United Kingdom Foreign, Commonwealth & Development Office (GSRA – *Forecasting Fatalities in Armed Conflict*), the Swedish Research Council (*DEMSCORE*), the Swedish Foundation for Strategic Environmental Research (*MISTRA Geopolitics*), the Norwegian MFA (*Conflict Trends* QZA-18/0227), and the United Nations High Commissioner for Refugees (*the Sahel Predictive Analytics project*).



%package help
Summary:	Development documents and examples for views-transformation-library
Provides:	python3-views-transformation-library-doc
%description help

# ViEWS Transformation Library

This package contains transforms made available in ViEWS cloud.  The transforms
are all locally available, and do not depend on remote resources or
credentials.

## Contributing: 

There is an urgent need to fill this library with transforms.
Transforms we need, that are not implemented, are listed under issues.
Please follow the guidelines for contributing outlined in the [CONTRIBUTING.md](CONTRIBUTING.md) document.

## Usage:

```
pip install views-transformation-library
```

```
from views_transformation_library.timelag import timelag
import viewser

ged_best_ns = viewser.get_variable("priogrid_month","priogrid_month.ged_best_ns",2010,2020)
lagged_data = timelag(ged_best_ns,10)

lagged_from_api = viewser.get_variable("priogrid_month","ged_best_ns",2010,2020,transforms:[
   {"type":"tlag","args":[10]}
])

assert lagged_from_api == lagged_data
```

## API:

Each transform function operates on a pandas dataframe.

## Funding

The contents of this repository is the outcome of projects that have received funding from the European Research Council (ERC) under the European Union’s Horizon 2020 research and innovation programme (Grant agreement No. 694640, *ViEWS*) and Horizon Europe (Grant agreement No. 101055176, *ANTICIPATE*; and No. 101069312, *ViEWS* (ERC-2022-POC1)), Riksbankens Jubileumsfond (Grant agreement No. M21-0002, *Societies at Risk*), Uppsala University, Peace Research Institute Oslo, the United Nations Economic and Social Commission for Western Asia (*ViEWS-ESCWA*), the United Kingdom Foreign, Commonwealth & Development Office (GSRA – *Forecasting Fatalities in Armed Conflict*), the Swedish Research Council (*DEMSCORE*), the Swedish Foundation for Strategic Environmental Research (*MISTRA Geopolitics*), the Norwegian MFA (*Conflict Trends* QZA-18/0227), and the United Nations High Commissioner for Refugees (*the Sahel Predictive Analytics project*).



%prep
%autosetup -n views-transformation-library-2.7.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-views-transformation-library -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.7.0-1
- Package Spec generated