%global _empty_manifest_terminate_build 0
Name:		python-alluxio
Version:	0.1.4
Release:	1
Summary:	Alluxio python client
License:	Apache-2.0
URL:		https://github.com/Alluxio/alluxio-py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b9/73/5e31913e8e77b13de0b9e829175478c74d38d1c911dc317baa57bc31dce3/alluxio-0.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-six
Requires:	python3-requests

%description
Alluxio python client based on REST API


%package -n python3-alluxio
Summary:	Alluxio python client
Provides:	python-alluxio
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-alluxio
Alluxio python client based on REST API


%package help
Summary:	Development documents and examples for alluxio
Provides:	python3-alluxio-doc
%description help
Alluxio python client based on REST API


%prep
%autosetup -n alluxio-0.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-alluxio -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
- Package Spec generated