%global _empty_manifest_terminate_build 0
Name: python-mountepy
Version: 0.4.1
Release: 1
Summary: Utilities for creating (micro)service tests. Based on Mountebank.
License: BSD Zero Clause
URL: https://github.com/butla/mountepy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/87/72/61ff89ec79b2ea70eb05b86c3bd186b5e4802c601dc3b952977b946ed22a/mountepy-0.4.1.tar.gz
BuildArch: noarch
Requires: python3-port-for
Requires: python3-dateutil
Requires: python3-requests
%description
Utilities for creating HTTP (micro)service tests. Based on `Mountebank `_.
Mountepy works by spawning and cleaning after given HTTP service
processes and Mountebank. Thanks to that you no longer need that "start X
before running the tests" for your application. No. Your tests start
"X", it's put up or down only when it needs to and as many times as you
need.
- Test-framework-agnostic (use unittest, nose, py.test or whatever...
but I like py.test).
- Enables fast and reliable end-to-end testing of microservices. They
won't be aware that they are in some testing mode.
- Tested on Python 3.4, Ubuntu 14 x64.
- Planned features in the road map below.
If you have suggestions, just post them as Github issues.
Pull requests are also welcome :)
I recommend Pytest for elastic composition of service process test
fixtures. Your process may start once per test suite, once per test,
etc.
%package -n python3-mountepy
Summary: Utilities for creating (micro)service tests. Based on Mountebank.
Provides: python-mountepy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mountepy
Utilities for creating HTTP (micro)service tests. Based on `Mountebank `_.
Mountepy works by spawning and cleaning after given HTTP service
processes and Mountebank. Thanks to that you no longer need that "start X
before running the tests" for your application. No. Your tests start
"X", it's put up or down only when it needs to and as many times as you
need.
- Test-framework-agnostic (use unittest, nose, py.test or whatever...
but I like py.test).
- Enables fast and reliable end-to-end testing of microservices. They
won't be aware that they are in some testing mode.
- Tested on Python 3.4, Ubuntu 14 x64.
- Planned features in the road map below.
If you have suggestions, just post them as Github issues.
Pull requests are also welcome :)
I recommend Pytest for elastic composition of service process test
fixtures. Your process may start once per test suite, once per test,
etc.
%package help
Summary: Development documents and examples for mountepy
Provides: python3-mountepy-doc
%description help
Utilities for creating HTTP (micro)service tests. Based on `Mountebank `_.
Mountepy works by spawning and cleaning after given HTTP service
processes and Mountebank. Thanks to that you no longer need that "start X
before running the tests" for your application. No. Your tests start
"X", it's put up or down only when it needs to and as many times as you
need.
- Test-framework-agnostic (use unittest, nose, py.test or whatever...
but I like py.test).
- Enables fast and reliable end-to-end testing of microservices. They
won't be aware that they are in some testing mode.
- Tested on Python 3.4, Ubuntu 14 x64.
- Planned features in the road map below.
If you have suggestions, just post them as Github issues.
Pull requests are also welcome :)
I recommend Pytest for elastic composition of service process test
fixtures. Your process may start once per test suite, once per test,
etc.
%prep
%autosetup -n mountepy-0.4.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mountepy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.4.1-1
- Package Spec generated