%global _empty_manifest_terminate_build 0
Name:		python-webex-skills
Version:	2.0.16
Release:	1
Summary:	An SDK for skills for the Webex Assistant.
License:	MIT
URL:		https://github.com/cisco/webex-assistant-sdk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d6/1a/91ee433d3c9423c44ee294750f8ef190f9529febf79b6641c356348e2132/webex-skills-2.0.16.tar.gz
BuildArch:	noarch

Requires:	python3-cryptography
Requires:	python3-mindmeld
Requires:	python3-requests
Requires:	python3-typer
Requires:	python3-pydantic[dotenv]
Requires:	python3-fastapi
Requires:	python3-uvicorn

%description
# Webex Assistant Skills SDK

The Webex Skills SDK is designed to simplify the process of creating a Webex Assistant Skill. It provides some
tools that help to easily set up a template skill, deal with encryption and test the skill locally, among other
things.

This is a simplified version of the documentation, for more information visit the official  
[Webex Assistant Skills SDK website](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide).

## Installing the SDK

This SDK supports `Python 3.7` and above. If you want to be able to build
[MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill),
you will need to use `Python 3.7` for compatibility with the [MindMeld library](https://www.mindmeld.com/).

### Using pip

Create a virtual environment with `Python 3.7`:

```python
pyenv install 3.7.5
pyenv virtualenv 3.7.5 webex-skills
pyenv local webex-skills
```

Install using `pip`:

```python
pip install webex-skills
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
pip install 'webex-skills[mindmeld]'
```

### Install from Source

You can install from source using `Poetry`. Set up python 3.7.5 locally:

```python
pyenv install 3.7.5
pyenv local 3.7.5
```

Now you can run `Poetry`'s `install` command:

```python
poetry install
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
poetry install --extras "mindmeld"
```


## Building Skills

You can follow the next guides for building your first skills:

- [Simple Skills vs MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#simple-skills-vs-mindmeld-skills)
- [Building a Simple Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-simple-skill)
- [Building a MindMeld Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill)


%package -n python3-webex-skills
Summary:	An SDK for skills for the Webex Assistant.
Provides:	python-webex-skills
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-webex-skills
# Webex Assistant Skills SDK

The Webex Skills SDK is designed to simplify the process of creating a Webex Assistant Skill. It provides some
tools that help to easily set up a template skill, deal with encryption and test the skill locally, among other
things.

This is a simplified version of the documentation, for more information visit the official  
[Webex Assistant Skills SDK website](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide).

## Installing the SDK

This SDK supports `Python 3.7` and above. If you want to be able to build
[MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill),
you will need to use `Python 3.7` for compatibility with the [MindMeld library](https://www.mindmeld.com/).

### Using pip

Create a virtual environment with `Python 3.7`:

```python
pyenv install 3.7.5
pyenv virtualenv 3.7.5 webex-skills
pyenv local webex-skills
```

Install using `pip`:

```python
pip install webex-skills
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
pip install 'webex-skills[mindmeld]'
```

### Install from Source

You can install from source using `Poetry`. Set up python 3.7.5 locally:

```python
pyenv install 3.7.5
pyenv local 3.7.5
```

Now you can run `Poetry`'s `install` command:

```python
poetry install
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
poetry install --extras "mindmeld"
```


## Building Skills

You can follow the next guides for building your first skills:

- [Simple Skills vs MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#simple-skills-vs-mindmeld-skills)
- [Building a Simple Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-simple-skill)
- [Building a MindMeld Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill)


%package help
Summary:	Development documents and examples for webex-skills
Provides:	python3-webex-skills-doc
%description help
# Webex Assistant Skills SDK

The Webex Skills SDK is designed to simplify the process of creating a Webex Assistant Skill. It provides some
tools that help to easily set up a template skill, deal with encryption and test the skill locally, among other
things.

This is a simplified version of the documentation, for more information visit the official  
[Webex Assistant Skills SDK website](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide).

## Installing the SDK

This SDK supports `Python 3.7` and above. If you want to be able to build
[MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill),
you will need to use `Python 3.7` for compatibility with the [MindMeld library](https://www.mindmeld.com/).

### Using pip

Create a virtual environment with `Python 3.7`:

```python
pyenv install 3.7.5
pyenv virtualenv 3.7.5 webex-skills
pyenv local webex-skills
```

Install using `pip`:

```python
pip install webex-skills
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
pip install 'webex-skills[mindmeld]'
```

### Install from Source

You can install from source using `Poetry`. Set up python 3.7.5 locally:

```python
pyenv install 3.7.5
pyenv local 3.7.5
```

Now you can run `Poetry`'s `install` command:

```python
poetry install
```

In order to build `MindMeld Skills` you need the `mindmeld` extra:

```python
poetry install --extras "mindmeld"
```


## Building Skills

You can follow the next guides for building your first skills:

- [Simple Skills vs MindMeld Skills](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#simple-skills-vs-mindmeld-skills)
- [Building a Simple Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-simple-skill)
- [Building a MindMeld Skill](https://developer.webex.com/docs/api/guides/webex-assistant-skills-guide#building-a-mindmeld-skill)


%prep
%autosetup -n webex-skills-2.0.16

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-webex-skills -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.16-1
- Package Spec generated