%global _empty_manifest_terminate_build 0
Name:		python-Brownie
Version:	0.5.1
Release:	1
Summary:	Common utilities and datastructures for Python applications.
License:	BSD
URL:		http://github.com/DasIch/brownie/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/49/c4/f8aa4d3946206e9847d8b3c67a68983f1f8dc149f00c6e86370c64a72a52/Brownie-0.5.1.tar.gz
BuildArch:	noarch


%description
- Have you ever started a new project and implemented this little function
  foo or this datastructure bar you already implemented for another project?
- Ever wondered why a specific feature is not in the `standard library`_
  already?
- Wanted to use that new datastructure but you are still stuck with this
  ancient Python version or are just not willing or able to switch to
  Python 3.x, yet?
- And most importantly were too lazy to implement this datastructure which
  would be more appropriate to use?
Brownie wants to solve these problems by providing all these small things
well documented, well tested and most importantly right now when you need
it.
Take a look at the documentation_ for further information, visit Github_
for development or issue tracking or fetch the `latest development version`_.

%package -n python3-Brownie
Summary:	Common utilities and datastructures for Python applications.
Provides:	python-Brownie
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Brownie
- Have you ever started a new project and implemented this little function
  foo or this datastructure bar you already implemented for another project?
- Ever wondered why a specific feature is not in the `standard library`_
  already?
- Wanted to use that new datastructure but you are still stuck with this
  ancient Python version or are just not willing or able to switch to
  Python 3.x, yet?
- And most importantly were too lazy to implement this datastructure which
  would be more appropriate to use?
Brownie wants to solve these problems by providing all these small things
well documented, well tested and most importantly right now when you need
it.
Take a look at the documentation_ for further information, visit Github_
for development or issue tracking or fetch the `latest development version`_.

%package help
Summary:	Development documents and examples for Brownie
Provides:	python3-Brownie-doc
%description help
- Have you ever started a new project and implemented this little function
  foo or this datastructure bar you already implemented for another project?
- Ever wondered why a specific feature is not in the `standard library`_
  already?
- Wanted to use that new datastructure but you are still stuck with this
  ancient Python version or are just not willing or able to switch to
  Python 3.x, yet?
- And most importantly were too lazy to implement this datastructure which
  would be more appropriate to use?
Brownie wants to solve these problems by providing all these small things
well documented, well tested and most importantly right now when you need
it.
Take a look at the documentation_ for further information, visit Github_
for development or issue tracking or fetch the `latest development version`_.

%prep
%autosetup -n Brownie-0.5.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Brownie -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
- Package Spec generated