%global _empty_manifest_terminate_build 0 Name: python-api-endpoint-manager Version: 0.0.12 Release: 1 Summary: This library contains classes to simplify the process of Flask API end points definition License: MIT URL: https://github.com/Quakingaspen-codehub/api_endpoint_manager Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/8a/287462c629b139792bc20d62b3a414b95f944f28828dcdad2099e58006e2/api_endpoint_manager-0.0.12.tar.gz BuildArch: noarch Requires: python3-http-request-response Requires: python3-http-request-args Requires: python3-flask-jwt-auth Requires: python3-flask-restplus %description
# api-endpoint [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This library contains classes to simplify the process of Flask API end points definition

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install api_endpoint_manager ```

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package -n python3-api-endpoint-manager Summary: This library contains classes to simplify the process of Flask API end points definition Provides: python-api-endpoint-manager BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-api-endpoint-manager
# api-endpoint [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This library contains classes to simplify the process of Flask API end points definition

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install api_endpoint_manager ```

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package help Summary: Development documents and examples for api-endpoint-manager Provides: python3-api-endpoint-manager-doc %description help
# api-endpoint [Introduction](#Introduction)\ [Getting Started](#Started)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This library contains classes to simplify the process of Flask API end points definition

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install api_endpoint_manager ```

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %prep %autosetup -n api-endpoint-manager-0.0.12 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-api-endpoint-manager -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 31 2023 Python_Bot - 0.0.12-1 - Package Spec generated