%global _empty_manifest_terminate_build 0
Name:		python-flashday
Version:	0.3.0
Release:	1
Summary:	Flashday event Django app
License:	GNU General Public License v3.0
URL:		https://github.com/pripessoaink/flashday
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f3/e8/63b4ffb9f5ef00595f27742a4ffb68990125174de7f10be6ad23c2496bca/flashday-0.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-Django
Requires:	python3-pip
Requires:	python3-setuptools
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-trove-classifiers
Requires:	python3-GitPython
Requires:	python3-requests

%description
# Flashday
> This intend to be an [readme-documented][-0], [open-source-licensed][-1], [semantic-versioned][-2],
[conventional-committed][-3] and [changelogged][-4] git repository for the development of a 
[pripessoaink][1] namespace's python package

Flashday event Django app

[-0]: https://www.makeareadme.com/ "Make a README"
[-1]: https://choosealicense.com/licenses/ "Choose a License"
[-2]: https://semver.org/ "Semantic Versioning"
[-3]: https://www.conventionalcommits.org/en/v1.0.0/ "Conventional Commits"
[-4]: https://keepachangelog.com/en/1.0.0/ "Keep a Changelog"
[-5]: https://www.repostatus.org "Repo maintenance status"

[1]: https://www.instagram.com/pripessoaink/ "Pripessoaink"

This package brings the tools to serve a Flashday event as a service through Django server


## Maintainance [![][B1]][-5]
This project is maintained by the author, [@artu-hnrq](https://github.com/artu-hnrq). \
It has reached a stable, usable state and is being **actively developed**.

[B1]: https://www.repostatus.org/badges/latest/active.svg "Repostatus active badge"


## License [![][B2]][2]
This project is published under the permissions established by [GNU General Public License v3.0][6].

[B2]: https://img.shields.io/github/license/artu-hnrq/Django_GoogleAppEngine_Template?color=green "License badge"
[2]: https://choosealicense.com/licenses/gpl-3.0/ "GPL 3.0 License description"




%package -n python3-flashday
Summary:	Flashday event Django app
Provides:	python-flashday
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flashday
# Flashday
> This intend to be an [readme-documented][-0], [open-source-licensed][-1], [semantic-versioned][-2],
[conventional-committed][-3] and [changelogged][-4] git repository for the development of a 
[pripessoaink][1] namespace's python package

Flashday event Django app

[-0]: https://www.makeareadme.com/ "Make a README"
[-1]: https://choosealicense.com/licenses/ "Choose a License"
[-2]: https://semver.org/ "Semantic Versioning"
[-3]: https://www.conventionalcommits.org/en/v1.0.0/ "Conventional Commits"
[-4]: https://keepachangelog.com/en/1.0.0/ "Keep a Changelog"
[-5]: https://www.repostatus.org "Repo maintenance status"

[1]: https://www.instagram.com/pripessoaink/ "Pripessoaink"

This package brings the tools to serve a Flashday event as a service through Django server


## Maintainance [![][B1]][-5]
This project is maintained by the author, [@artu-hnrq](https://github.com/artu-hnrq). \
It has reached a stable, usable state and is being **actively developed**.

[B1]: https://www.repostatus.org/badges/latest/active.svg "Repostatus active badge"


## License [![][B2]][2]
This project is published under the permissions established by [GNU General Public License v3.0][6].

[B2]: https://img.shields.io/github/license/artu-hnrq/Django_GoogleAppEngine_Template?color=green "License badge"
[2]: https://choosealicense.com/licenses/gpl-3.0/ "GPL 3.0 License description"




%package help
Summary:	Development documents and examples for flashday
Provides:	python3-flashday-doc
%description help
# Flashday
> This intend to be an [readme-documented][-0], [open-source-licensed][-1], [semantic-versioned][-2],
[conventional-committed][-3] and [changelogged][-4] git repository for the development of a 
[pripessoaink][1] namespace's python package

Flashday event Django app

[-0]: https://www.makeareadme.com/ "Make a README"
[-1]: https://choosealicense.com/licenses/ "Choose a License"
[-2]: https://semver.org/ "Semantic Versioning"
[-3]: https://www.conventionalcommits.org/en/v1.0.0/ "Conventional Commits"
[-4]: https://keepachangelog.com/en/1.0.0/ "Keep a Changelog"
[-5]: https://www.repostatus.org "Repo maintenance status"

[1]: https://www.instagram.com/pripessoaink/ "Pripessoaink"

This package brings the tools to serve a Flashday event as a service through Django server


## Maintainance [![][B1]][-5]
This project is maintained by the author, [@artu-hnrq](https://github.com/artu-hnrq). \
It has reached a stable, usable state and is being **actively developed**.

[B1]: https://www.repostatus.org/badges/latest/active.svg "Repostatus active badge"


## License [![][B2]][2]
This project is published under the permissions established by [GNU General Public License v3.0][6].

[B2]: https://img.shields.io/github/license/artu-hnrq/Django_GoogleAppEngine_Template?color=green "License badge"
[2]: https://choosealicense.com/licenses/gpl-3.0/ "GPL 3.0 License description"




%prep
%autosetup -n flashday-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flashday -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated