%global _empty_manifest_terminate_build 0
Name:		python-ocldev
Version:	0.1.92
Release:	1
Summary:	Python development library for working with OCL resources and APIs
License:	MPL2.0
URL:		http://github.com/OpenConceptLab/ocldev
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/82/45/78edb96a3ed56bafe6f1d95b1ccb86f0850942b17592c040ff1253334f70/ocldev-0.1.92.tar.gz
BuildArch:	noarch

Requires:	python3-jsonschema
Requires:	python3-requests

%description
# ocldev
Development library for working with OCL metadata and APIs

`ocldev` package is published to PyPi, which means you can easily install it with pip, eg:
```
pip install ocldev
```

These classes are implemented currently:
* OclResourceList, OclCsvResourceList, OclJsonResourceList - 
* OclFlexImporter & OclBulkImporter - Used to import JSON resources into OCL
* OclImportResults - Used to process the results of an import
* OclExport & OclExportFactory - Used to fetch exports from OCL
* OclCsvToJsonConverter - Used to convert CSV files to OCL-formatted JSON
* OclValidator - Validates OCL-formatted JSON and CSV resources and resource lists

## Deployment to PyPi
OCL's continuous integration service (Bamboo) offers two custom build plans to deploy the `ocldev` package to the test or the production PyPi servers. PyPi requires that the version number is unique in https://github.com/OpenConceptLab/ocldev/blob/master/setup.py#L8, otherwise PyPi will return an error. A user account is required to access OCL's CI service.




%package -n python3-ocldev
Summary:	Python development library for working with OCL resources and APIs
Provides:	python-ocldev
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ocldev
# ocldev
Development library for working with OCL metadata and APIs

`ocldev` package is published to PyPi, which means you can easily install it with pip, eg:
```
pip install ocldev
```

These classes are implemented currently:
* OclResourceList, OclCsvResourceList, OclJsonResourceList - 
* OclFlexImporter & OclBulkImporter - Used to import JSON resources into OCL
* OclImportResults - Used to process the results of an import
* OclExport & OclExportFactory - Used to fetch exports from OCL
* OclCsvToJsonConverter - Used to convert CSV files to OCL-formatted JSON
* OclValidator - Validates OCL-formatted JSON and CSV resources and resource lists

## Deployment to PyPi
OCL's continuous integration service (Bamboo) offers two custom build plans to deploy the `ocldev` package to the test or the production PyPi servers. PyPi requires that the version number is unique in https://github.com/OpenConceptLab/ocldev/blob/master/setup.py#L8, otherwise PyPi will return an error. A user account is required to access OCL's CI service.




%package help
Summary:	Development documents and examples for ocldev
Provides:	python3-ocldev-doc
%description help
# ocldev
Development library for working with OCL metadata and APIs

`ocldev` package is published to PyPi, which means you can easily install it with pip, eg:
```
pip install ocldev
```

These classes are implemented currently:
* OclResourceList, OclCsvResourceList, OclJsonResourceList - 
* OclFlexImporter & OclBulkImporter - Used to import JSON resources into OCL
* OclImportResults - Used to process the results of an import
* OclExport & OclExportFactory - Used to fetch exports from OCL
* OclCsvToJsonConverter - Used to convert CSV files to OCL-formatted JSON
* OclValidator - Validates OCL-formatted JSON and CSV resources and resource lists

## Deployment to PyPi
OCL's continuous integration service (Bamboo) offers two custom build plans to deploy the `ocldev` package to the test or the production PyPi servers. PyPi requires that the version number is unique in https://github.com/OpenConceptLab/ocldev/blob/master/setup.py#L8, otherwise PyPi will return an error. A user account is required to access OCL's CI service.




%prep
%autosetup -n ocldev-0.1.92

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ocldev -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.92-1
- Package Spec generated