%global _empty_manifest_terminate_build 0
Name:		python-EasyMuse
Version:	0.1.5
Release:	1
Summary:	A Python library for connecting and communicate with MUSE headbands. Uses Bleak as the underlying Bluetooth interface.
License:	MIT
URL:		https://github.com/bardiabarabadi/EasyMuse
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/81/95/fc33fd43a6b5a0cad4bf0e060b6ba3ddfea140f72c5aa50995349e7db998/EasyMuse-0.1.5.tar.gz
BuildArch:	noarch

Requires:	python3-bitstring
Requires:	python3-numpy
Requires:	python3-seaborn
Requires:	python3-pexpect
Requires:	python3-bleak
Requires:	python3-pygments
Requires:	python3-pyserial
Requires:	python3-esptool
Requires:	python3-nest-asyncio

%description


%package -n python3-EasyMuse
Summary:	A Python library for connecting and communicate with MUSE headbands. Uses Bleak as the underlying Bluetooth interface.
Provides:	python-EasyMuse
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-EasyMuse


%package help
Summary:	Development documents and examples for EasyMuse
Provides:	python3-EasyMuse-doc
%description help


%prep
%autosetup -n EasyMuse-0.1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-EasyMuse -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
- Package Spec generated