%global _empty_manifest_terminate_build 0 Name: python-yqn-project-cli Version: 0.0.0rc89 Release: 1 Summary: For more faster to create semi-project based on flask License: MIT License URL: https://blog.zoukaihua.com Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/83/773a2fdb6124a841b1fb80a967a11a33164326703a08e69a1ad9ff5d1682/yqn_project_cli-0.0.0rc89.tar.gz BuildArch: noarch Requires: python3-DBUtils Requires: python3-Flask Requires: python3-Flask-Compress Requires: python3-Flask-Cors Requires: python3-flask-restx Requires: python3-PyMySQL Requires: python3-pyodps Requires: python3-requests Requires: python3-requests-toolbelt Requires: python3-termcolor Requires: python3-gevent Requires: python3-gunicorn %description # yqn_project_cli #### For more faster to create semi-project based on flask ##console runner ####new_json_config_file由初始项目json_config_file复制过来,后续整个项目生命周期的路由部分以新文件为依据
初始化项目:yqn-project -c absolute_json_config_file_path

初始化或更新module:yqn-autoview - c new_json_config_file_path
##json-config-file format: ```json { "app_id": 22010, "app_name": "project_name", "app_path": "absolute_project_dir_path", "path_list": [ { "path": "/index/", "module": "main", "view_cls": "Index", "view_mth": "get_index", "http_methods": ["GET", "POST"], "doc": "默认" }, { "path": "/tool/", "module": "tool", "view_cls": "Index", "view_mth": "get_tool", "http_methods": ["GET", "POST"], "doc": "工具" } ] } ``` ##json-file参数解释:
app_id:项目唯一数字标识

项目(app_name)位于路径(app_path)下

path_list:所有需路由对象信息数组

path: http请求路径

module: api下的对应模块,便于分块,如 main、tool

view_cls: api对应模块下views.py文件内的视图类, 如 Index

view_mth: 对应视图类下实例方法, 如 get_index、get_tool,http请求时产生调用

http_methods: 支持http请求方式

doc: 方法doc描述
**** ##初始项目结构描述(api/common/config/rpc/scripts/thirds/utils,以及入口和打包文件) ###api:接口模块 #####api.*子模块: ######1.handler:功能逻辑 ######2.model:模型定义 ######3.parser:参数解析校验 ######4.views:视图逻辑

###common:通用或不明晰模块

###config:项目配置

###rpc(http):调用封装

###scripts:脚本罗列

###thirds:三方插件

###utils:功能函数

###其他:一些入口或打包文件 %package -n python3-yqn-project-cli Summary: For more faster to create semi-project based on flask Provides: python-yqn-project-cli BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-yqn-project-cli # yqn_project_cli #### For more faster to create semi-project based on flask ##console runner ####new_json_config_file由初始项目json_config_file复制过来,后续整个项目生命周期的路由部分以新文件为依据
初始化项目:yqn-project -c absolute_json_config_file_path

初始化或更新module:yqn-autoview - c new_json_config_file_path
##json-config-file format: ```json { "app_id": 22010, "app_name": "project_name", "app_path": "absolute_project_dir_path", "path_list": [ { "path": "/index/", "module": "main", "view_cls": "Index", "view_mth": "get_index", "http_methods": ["GET", "POST"], "doc": "默认" }, { "path": "/tool/", "module": "tool", "view_cls": "Index", "view_mth": "get_tool", "http_methods": ["GET", "POST"], "doc": "工具" } ] } ``` ##json-file参数解释:
app_id:项目唯一数字标识

项目(app_name)位于路径(app_path)下

path_list:所有需路由对象信息数组

path: http请求路径

module: api下的对应模块,便于分块,如 main、tool

view_cls: api对应模块下views.py文件内的视图类, 如 Index

view_mth: 对应视图类下实例方法, 如 get_index、get_tool,http请求时产生调用

http_methods: 支持http请求方式

doc: 方法doc描述
**** ##初始项目结构描述(api/common/config/rpc/scripts/thirds/utils,以及入口和打包文件) ###api:接口模块 #####api.*子模块: ######1.handler:功能逻辑 ######2.model:模型定义 ######3.parser:参数解析校验 ######4.views:视图逻辑

###common:通用或不明晰模块

###config:项目配置

###rpc(http):调用封装

###scripts:脚本罗列

###thirds:三方插件

###utils:功能函数

###其他:一些入口或打包文件 %package help Summary: Development documents and examples for yqn-project-cli Provides: python3-yqn-project-cli-doc %description help # yqn_project_cli #### For more faster to create semi-project based on flask ##console runner ####new_json_config_file由初始项目json_config_file复制过来,后续整个项目生命周期的路由部分以新文件为依据
初始化项目:yqn-project -c absolute_json_config_file_path

初始化或更新module:yqn-autoview - c new_json_config_file_path
##json-config-file format: ```json { "app_id": 22010, "app_name": "project_name", "app_path": "absolute_project_dir_path", "path_list": [ { "path": "/index/", "module": "main", "view_cls": "Index", "view_mth": "get_index", "http_methods": ["GET", "POST"], "doc": "默认" }, { "path": "/tool/", "module": "tool", "view_cls": "Index", "view_mth": "get_tool", "http_methods": ["GET", "POST"], "doc": "工具" } ] } ``` ##json-file参数解释:
app_id:项目唯一数字标识

项目(app_name)位于路径(app_path)下

path_list:所有需路由对象信息数组

path: http请求路径

module: api下的对应模块,便于分块,如 main、tool

view_cls: api对应模块下views.py文件内的视图类, 如 Index

view_mth: 对应视图类下实例方法, 如 get_index、get_tool,http请求时产生调用

http_methods: 支持http请求方式

doc: 方法doc描述
**** ##初始项目结构描述(api/common/config/rpc/scripts/thirds/utils,以及入口和打包文件) ###api:接口模块 #####api.*子模块: ######1.handler:功能逻辑 ######2.model:模型定义 ######3.parser:参数解析校验 ######4.views:视图逻辑

###common:通用或不明晰模块

###config:项目配置

###rpc(http):调用封装

###scripts:脚本罗列

###thirds:三方插件

###utils:功能函数

###其他:一些入口或打包文件 %prep %autosetup -n yqn-project-cli-0.0.0rc89 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-yqn-project-cli -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 31 2023 Python_Bot - 0.0.0rc89-1 - Package Spec generated