%global _empty_manifest_terminate_build 0
Name: python-ai-benchmark
Version: 0.1.2
Release: 1
Summary: AI Benchmark is an open source python library for evaluating AI performance of various hardware platforms, including CPUs, GPUs and TPUs.
License: Apache License Version 2.0
URL: http://ai-benchmark.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/99/9e/6685285db14f407d5061e6022f96400f6fe958a70ba320472178151ded4b/ai-benchmark-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-psutil
Requires: python3-py-cpuinfo
Requires: python3-pillow
Requires: python3-setuptools
Requires: python3-requests
%description
[AI Benchmark Alpha](http://ai-benchmark.com/alpha) is an open source python library for evaluating AI performance of various hardware platforms, including CPUs, GPUs and TPUs. The benchmark is relying on [TensorFlow](https://www.tensorflow.org) machine learning library, and is providing a lightweight and accurate solution for assessing inference and training speed for key Deep Learning models.
In total, AI Benchmark consists of 42 tests and 19 sections provided below:
1. MobileNet-V2 `[classification]`
2. Inception-V3 `[classification]`
3. Inception-V4 `[classification]`
4. Inception-ResNet-V2 `[classification]`
5. ResNet-V2-50 `[classification]`
6. ResNet-V2-152 `[classification]`
7. VGG-16 `[classification]`
8. SRCNN 9-5-5 `[image-to-image mapping]`
9. VGG-19 `[image-to-image mapping]`
10. ResNet-SRGAN `[image-to-image mapping]`
11. ResNet-DPED `[image-to-image mapping]`
12. U-Net `[image-to-image mapping]`
13. Nvidia-SPADE `[image-to-image mapping]`
14. ICNet `[image segmentation]`
15. PSPNet `[image segmentation]`
16. DeepLab `[image segmentation]`
17. Pixel-RNN `[inpainting]`
18. LSTM `[sentence sentiment analysis]`
19. GNMT `[text translation]`
For more information and results, please visit the project website: [http://ai-benchmark.com/alpha](http://ai-benchmark.com/alpha)
#### Installation Instructions
The benchmark requires TensorFlow machine learning library to be present in your system.
On systems that do not have Nvidia GPUs, run the following commands to install AI Benchmark:
```bash
pip install tensorflow
pip install ai-benchmark
```
If you want to check the performance of Nvidia graphic cards, run the following commands:
```bash
pip install tensorflow-gpu
pip install ai-benchmark
```
`Note 1:` If Tensorflow is already installed in your system, you can skip the first command.
`Note 2:` For running the benchmark on Nvidia GPUs, `NVIDIA CUDA` and `cuDNN` libraries should be installed first. Please find detailed instructions [here](https://www.tensorflow.org/install/gpu).
#### Getting Started
To run AI Benchmark, use the following code:
```bash
from ai_benchmark import AIBenchmark
benchmark = AIBenchmark()
results = benchmark.run()
```
Alternatively, on Linux systems you can type `ai-benchmark` in the command line to start the tests.
To run inference or training only, use `benchmark.run_inference()` or `benchmark.run_training()`.
#### Advanced settings
```bash
AIBenchmark(use_CPU=None, verbose_level=1):
```
> use_CPU=`{True, False, None}`: whether to run the tests on CPUs (if tensorflow-gpu is installed)
> verbose_level=`{0, 1, 2, 3}`: run tests silently | with short summary | with information about each run | with TF logs
```bash
benchmark.run(precision="normal"):
```
> precision=`{"normal", "high"}`: if `high` is selected, the benchmark will execute 10 times more runs for each test.
### Additional Notes and Requirements
GPU with at least 2GB of RAM is required for running inference tests / 4GB of RAM for training tests.
The benchmark is compatible with both `TensorFlow 1.x` and `2.x` versions.
### Contacts
Please contact `andrey@vision.ee.ethz.ch` for any feedback or information.
%package -n python3-ai-benchmark
Summary: AI Benchmark is an open source python library for evaluating AI performance of various hardware platforms, including CPUs, GPUs and TPUs.
Provides: python-ai-benchmark
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ai-benchmark
[AI Benchmark Alpha](http://ai-benchmark.com/alpha) is an open source python library for evaluating AI performance of various hardware platforms, including CPUs, GPUs and TPUs. The benchmark is relying on [TensorFlow](https://www.tensorflow.org) machine learning library, and is providing a lightweight and accurate solution for assessing inference and training speed for key Deep Learning models.
In total, AI Benchmark consists of 42 tests and 19 sections provided below:
1. MobileNet-V2 `[classification]`
2. Inception-V3 `[classification]`
3. Inception-V4 `[classification]`
4. Inception-ResNet-V2 `[classification]`
5. ResNet-V2-50 `[classification]`
6. ResNet-V2-152 `[classification]`
7. VGG-16 `[classification]`
8. SRCNN 9-5-5 `[image-to-image mapping]`
9. VGG-19 `[image-to-image mapping]`
10. ResNet-SRGAN `[image-to-image mapping]`
11. ResNet-DPED `[image-to-image mapping]`
12. U-Net `[image-to-image mapping]`
13. Nvidia-SPADE `[image-to-image mapping]`
14. ICNet `[image segmentation]`
15. PSPNet `[image segmentation]`
16. DeepLab `[image segmentation]`
17. Pixel-RNN `[inpainting]`
18. LSTM `[sentence sentiment analysis]`
19. GNMT `[text translation]`
For more information and results, please visit the project website: [http://ai-benchmark.com/alpha](http://ai-benchmark.com/alpha)
#### Installation Instructions
The benchmark requires TensorFlow machine learning library to be present in your system.
On systems that do not have Nvidia GPUs, run the following commands to install AI Benchmark:
```bash
pip install tensorflow
pip install ai-benchmark
```
If you want to check the performance of Nvidia graphic cards, run the following commands:
```bash
pip install tensorflow-gpu
pip install ai-benchmark
```
`Note 1:` If Tensorflow is already installed in your system, you can skip the first command.
`Note 2:` For running the benchmark on Nvidia GPUs, `NVIDIA CUDA` and `cuDNN` libraries should be installed first. Please find detailed instructions [here](https://www.tensorflow.org/install/gpu).
#### Getting Started
To run AI Benchmark, use the following code:
```bash
from ai_benchmark import AIBenchmark
benchmark = AIBenchmark()
results = benchmark.run()
```
Alternatively, on Linux systems you can type `ai-benchmark` in the command line to start the tests.
To run inference or training only, use `benchmark.run_inference()` or `benchmark.run_training()`.
#### Advanced settings
```bash
AIBenchmark(use_CPU=None, verbose_level=1):
```
> use_CPU=`{True, False, None}`: whether to run the tests on CPUs (if tensorflow-gpu is installed)
> verbose_level=`{0, 1, 2, 3}`: run tests silently | with short summary | with information about each run | with TF logs
```bash
benchmark.run(precision="normal"):
```
> precision=`{"normal", "high"}`: if `high` is selected, the benchmark will execute 10 times more runs for each test.
### Additional Notes and Requirements
GPU with at least 2GB of RAM is required for running inference tests / 4GB of RAM for training tests.
The benchmark is compatible with both `TensorFlow 1.x` and `2.x` versions.
### Contacts
Please contact `andrey@vision.ee.ethz.ch` for any feedback or information.
%package help
Summary: Development documents and examples for ai-benchmark
Provides: python3-ai-benchmark-doc
%description help
[AI Benchmark Alpha](http://ai-benchmark.com/alpha) is an open source python library for evaluating AI performance of various hardware platforms, including CPUs, GPUs and TPUs. The benchmark is relying on [TensorFlow](https://www.tensorflow.org) machine learning library, and is providing a lightweight and accurate solution for assessing inference and training speed for key Deep Learning models.
In total, AI Benchmark consists of 42 tests and 19 sections provided below:
1. MobileNet-V2 `[classification]`
2. Inception-V3 `[classification]`
3. Inception-V4 `[classification]`
4. Inception-ResNet-V2 `[classification]`
5. ResNet-V2-50 `[classification]`
6. ResNet-V2-152 `[classification]`
7. VGG-16 `[classification]`
8. SRCNN 9-5-5 `[image-to-image mapping]`
9. VGG-19 `[image-to-image mapping]`
10. ResNet-SRGAN `[image-to-image mapping]`
11. ResNet-DPED `[image-to-image mapping]`
12. U-Net `[image-to-image mapping]`
13. Nvidia-SPADE `[image-to-image mapping]`
14. ICNet `[image segmentation]`
15. PSPNet `[image segmentation]`
16. DeepLab `[image segmentation]`
17. Pixel-RNN `[inpainting]`
18. LSTM `[sentence sentiment analysis]`
19. GNMT `[text translation]`
For more information and results, please visit the project website: [http://ai-benchmark.com/alpha](http://ai-benchmark.com/alpha)
#### Installation Instructions
The benchmark requires TensorFlow machine learning library to be present in your system.
On systems that do not have Nvidia GPUs, run the following commands to install AI Benchmark:
```bash
pip install tensorflow
pip install ai-benchmark
```
If you want to check the performance of Nvidia graphic cards, run the following commands:
```bash
pip install tensorflow-gpu
pip install ai-benchmark
```
`Note 1:` If Tensorflow is already installed in your system, you can skip the first command.
`Note 2:` For running the benchmark on Nvidia GPUs, `NVIDIA CUDA` and `cuDNN` libraries should be installed first. Please find detailed instructions [here](https://www.tensorflow.org/install/gpu).
#### Getting Started
To run AI Benchmark, use the following code:
```bash
from ai_benchmark import AIBenchmark
benchmark = AIBenchmark()
results = benchmark.run()
```
Alternatively, on Linux systems you can type `ai-benchmark` in the command line to start the tests.
To run inference or training only, use `benchmark.run_inference()` or `benchmark.run_training()`.
#### Advanced settings
```bash
AIBenchmark(use_CPU=None, verbose_level=1):
```
> use_CPU=`{True, False, None}`: whether to run the tests on CPUs (if tensorflow-gpu is installed)
> verbose_level=`{0, 1, 2, 3}`: run tests silently | with short summary | with information about each run | with TF logs
```bash
benchmark.run(precision="normal"):
```
> precision=`{"normal", "high"}`: if `high` is selected, the benchmark will execute 10 times more runs for each test.
### Additional Notes and Requirements
GPU with at least 2GB of RAM is required for running inference tests / 4GB of RAM for training tests.
The benchmark is compatible with both `TensorFlow 1.x` and `2.x` versions.
### Contacts
Please contact `andrey@vision.ee.ethz.ch` for any feedback or information.
%prep
%autosetup -n ai-benchmark-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ai-benchmark -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.1.2-1
- Package Spec generated