%global _empty_manifest_terminate_build 0
Name:		python-django-simple-log
Version:	0.3.10
Release:	1
Summary:	Logging django models changes.
License:	BSD License
URL:		https://github.com/kindlycat/django-simple-log/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/09/57/688cfb00bb940f74f27ecb8ad40605ebe8a980bf31c331e96909a4bf4271/django-simple-log-0.3.10.tar.gz
BuildArch:	noarch

Requires:	python3-Django
Requires:	python3-django-request-vars

%description
Logging model changes on every create/update/delete (except queryset update).
Full documentation on `read the docs`_.

%package -n python3-django-simple-log
Summary:	Logging django models changes.
Provides:	python-django-simple-log
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-simple-log
Logging model changes on every create/update/delete (except queryset update).
Full documentation on `read the docs`_.

%package help
Summary:	Development documents and examples for django-simple-log
Provides:	python3-django-simple-log-doc
%description help
Logging model changes on every create/update/delete (except queryset update).
Full documentation on `read the docs`_.

%prep
%autosetup -n django-simple-log-0.3.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-simple-log -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.10-1
- Package Spec generated