%global _empty_manifest_terminate_build 0
Name:		python-vipy
Version:	1.14.4
Release:	1
Summary:	Python Tools for Visual Dataset Transformation
License:	MIT License
URL:		https://github.com/visym/vipy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b6/d0/380f52b8ce9592c492a4be369ad25c0ce31d6de7e1ef3e0fe29ab70b3187/vipy-1.14.4.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-dill
Requires:	python3-pillow
Requires:	python3-ffmpeg-python
Requires:	python3-scikit-build
Requires:	python3-scipy
Requires:	python3-opencv-python
Requires:	python3-torch
Requires:	python3-ipython
Requires:	python3-scikit-learn
Requires:	python3-boto3
Requires:	python3-youtube-dl
Requires:	python3-dask
Requires:	python3-distributed
Requires:	python3-h5py
Requires:	python3-nltk
Requires:	python3-bs4
Requires:	python3-pyyaml
Requires:	python3-pytest
Requires:	python3-paramiko
Requires:	python3-scp
Requires:	python3-ujson
Requires:	python3-pdoc3
Requires:	python3-dill
Requires:	python3-pillow
Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-ffmpeg-python
Requires:	python3-heyvi
Requires:	python3-scikit-build
Requires:	python3-scipy
Requires:	python3-opencv-python
Requires:	python3-torch
Requires:	python3-ipython
Requires:	python3-scikit-learn
Requires:	python3-boto3
Requires:	python3-youtube-dl
Requires:	python3-dask
Requires:	python3-distributed
Requires:	python3-h5py
Requires:	python3-nltk
Requires:	python3-bs4
Requires:	python3-pyyaml
Requires:	python3-pytest
Requires:	python3-paramiko
Requires:	python3-scp
Requires:	python3-ujson
Requires:	python3-numba
Requires:	python3-pdoc3
Requires:	python3-dill
Requires:	python3-pillow
Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-ffmpeg-python
Requires:	python3-heyvi
Requires:	python3-ujson
Requires:	python3-numba

%description
VIPY: Python Tools for Visual Dataset Transformation    
Documentation: https://visym.github.io/vipy
VIPY is a python package for representation, transformation and visualization of annotated videos and images.  Annotations are the ground truth provided by labelers (e.g. object bounding boxes, face identities, temporal activity clips), suitable for training computer vision systems.  VIPY provides tools to easily edit videos and images so that the annotations are transformed along with the pixels.  This enables a clean interface for transforming complex datasets for input to your computer vision training and testing pipeline.
VIPY provides:  
* Representation of videos with labeled activities that can be resized, clipped, rotated, scaled, padded, cropped and resampled
* Representation of images with object bounding boxes that can be manipulated as easily as editing an image
* Clean visualization of annotated images and videos 
* Lazy loading of images and videos suitable for distributed processing (e.g. dask, spark)
* Straightforward integration into machine learning toolchains (e.g. torch, numpy)
* Fluent interface for chaining operations on videos and images
* Dataset download, unpack and import (e.g. Charades, AVA, ActivityNet, Kinetics, Moments in Time)
* Minimum dependencies for easy installation (e.g. AWS Lambda, Flask)
[![VIPY MEVA dataset visualization](http://i3.ytimg.com/vi/_jixHQr5dK4/maxresdefault.jpg)](https://youtu.be/_jixHQr5dK4)

%package -n python3-vipy
Summary:	Python Tools for Visual Dataset Transformation
Provides:	python-vipy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vipy
VIPY: Python Tools for Visual Dataset Transformation    
Documentation: https://visym.github.io/vipy
VIPY is a python package for representation, transformation and visualization of annotated videos and images.  Annotations are the ground truth provided by labelers (e.g. object bounding boxes, face identities, temporal activity clips), suitable for training computer vision systems.  VIPY provides tools to easily edit videos and images so that the annotations are transformed along with the pixels.  This enables a clean interface for transforming complex datasets for input to your computer vision training and testing pipeline.
VIPY provides:  
* Representation of videos with labeled activities that can be resized, clipped, rotated, scaled, padded, cropped and resampled
* Representation of images with object bounding boxes that can be manipulated as easily as editing an image
* Clean visualization of annotated images and videos 
* Lazy loading of images and videos suitable for distributed processing (e.g. dask, spark)
* Straightforward integration into machine learning toolchains (e.g. torch, numpy)
* Fluent interface for chaining operations on videos and images
* Dataset download, unpack and import (e.g. Charades, AVA, ActivityNet, Kinetics, Moments in Time)
* Minimum dependencies for easy installation (e.g. AWS Lambda, Flask)
[![VIPY MEVA dataset visualization](http://i3.ytimg.com/vi/_jixHQr5dK4/maxresdefault.jpg)](https://youtu.be/_jixHQr5dK4)

%package help
Summary:	Development documents and examples for vipy
Provides:	python3-vipy-doc
%description help
VIPY: Python Tools for Visual Dataset Transformation    
Documentation: https://visym.github.io/vipy
VIPY is a python package for representation, transformation and visualization of annotated videos and images.  Annotations are the ground truth provided by labelers (e.g. object bounding boxes, face identities, temporal activity clips), suitable for training computer vision systems.  VIPY provides tools to easily edit videos and images so that the annotations are transformed along with the pixels.  This enables a clean interface for transforming complex datasets for input to your computer vision training and testing pipeline.
VIPY provides:  
* Representation of videos with labeled activities that can be resized, clipped, rotated, scaled, padded, cropped and resampled
* Representation of images with object bounding boxes that can be manipulated as easily as editing an image
* Clean visualization of annotated images and videos 
* Lazy loading of images and videos suitable for distributed processing (e.g. dask, spark)
* Straightforward integration into machine learning toolchains (e.g. torch, numpy)
* Fluent interface for chaining operations on videos and images
* Dataset download, unpack and import (e.g. Charades, AVA, ActivityNet, Kinetics, Moments in Time)
* Minimum dependencies for easy installation (e.g. AWS Lambda, Flask)
[![VIPY MEVA dataset visualization](http://i3.ytimg.com/vi/_jixHQr5dK4/maxresdefault.jpg)](https://youtu.be/_jixHQr5dK4)

%prep
%autosetup -n vipy-1.14.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vipy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.14.4-1
- Package Spec generated