%global _empty_manifest_terminate_build 0
Name: python-2Keys
Version: 0.5.1
Release: 1
Summary: A easy to setup second keyboard, designed for everyone.
License: GPLv3
URL: https://github.com/Gum-Joe/2Keys
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/6e/ab56fdb1addd3cff4bddbca9a125582ed16e1d8403080e7b5d8cdc349c34/2Keys-0.5.1.tar.gz
BuildArch: noarch
Requires: python3-aiofiles
Requires: python3-aiohttp
Requires: python3-async-timeout
Requires: python3-attrs
Requires: python3-certifi
Requires: python3-chardet
Requires: python3-click
Requires: python3-colorful
Requires: python3-colorful
Requires: python3-evdev
Requires: python3-idna
Requires: python3-idna-ssl
Requires: python3-multidict
Requires: python3-pystache
Requires: python3-pyyaml
Requires: python3-requests
Requires: python3-typing-extensions
Requires: python3-urllib3
Requires: python3-yarl
%description
# 2Keys
A easy to setup second keyboard, designed for everyone.
For a full setup guide, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/SETUP.md)
For keyboard mappings, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/MAPPINGS.md)
### Support
Windows is supported only as the server (where the hotkeys will run) and a raspberry pi is required to run the detector.
## WARNING
This will download a copy of [AutoHotkey_H](https://hotkeyit.github.io/v2/), a DLL version of [AutoHotkey](http://autohotkey.com/)
## Building
To build the server, where hotkeys are run:
```
$ cd server
$ yarn
```
To build the detector:
```
$ cd detector
$ pip3 install -r required.txt
```
## Devices
**Server**: The device running the hotkeys sever, i.e. where the hot keys will be run
**Detecter**: Device that handles detection of key presses & which keyboard it is and sends this to the server
## Sofware used & inspiration
Inspired by LTT editor Taran's second keyboard project: [https://github.com/TaranVH/2nd-keyboard](https://github.com/TaranVH/2nd-keyboard)
2Keys uses AutoHotkey_H (a DLL version of AutoHotkey): [https://hotkeyit.github.io/v2/](https://hotkeyit.github.io/v2/)
## License
Copyright 2018 Kishan Sambhi
2Keys is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
2Keys is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with 2Keys. If not, see .
%package -n python3-2Keys
Summary: A easy to setup second keyboard, designed for everyone.
Provides: python-2Keys
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-2Keys
# 2Keys
A easy to setup second keyboard, designed for everyone.
For a full setup guide, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/SETUP.md)
For keyboard mappings, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/MAPPINGS.md)
### Support
Windows is supported only as the server (where the hotkeys will run) and a raspberry pi is required to run the detector.
## WARNING
This will download a copy of [AutoHotkey_H](https://hotkeyit.github.io/v2/), a DLL version of [AutoHotkey](http://autohotkey.com/)
## Building
To build the server, where hotkeys are run:
```
$ cd server
$ yarn
```
To build the detector:
```
$ cd detector
$ pip3 install -r required.txt
```
## Devices
**Server**: The device running the hotkeys sever, i.e. where the hot keys will be run
**Detecter**: Device that handles detection of key presses & which keyboard it is and sends this to the server
## Sofware used & inspiration
Inspired by LTT editor Taran's second keyboard project: [https://github.com/TaranVH/2nd-keyboard](https://github.com/TaranVH/2nd-keyboard)
2Keys uses AutoHotkey_H (a DLL version of AutoHotkey): [https://hotkeyit.github.io/v2/](https://hotkeyit.github.io/v2/)
## License
Copyright 2018 Kishan Sambhi
2Keys is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
2Keys is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with 2Keys. If not, see .
%package help
Summary: Development documents and examples for 2Keys
Provides: python3-2Keys-doc
%description help
# 2Keys
A easy to setup second keyboard, designed for everyone.
For a full setup guide, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/SETUP.md)
For keyboard mappings, see [here](https://github.com/Gum-Joe/2Keys/blob/master/docs/MAPPINGS.md)
### Support
Windows is supported only as the server (where the hotkeys will run) and a raspberry pi is required to run the detector.
## WARNING
This will download a copy of [AutoHotkey_H](https://hotkeyit.github.io/v2/), a DLL version of [AutoHotkey](http://autohotkey.com/)
## Building
To build the server, where hotkeys are run:
```
$ cd server
$ yarn
```
To build the detector:
```
$ cd detector
$ pip3 install -r required.txt
```
## Devices
**Server**: The device running the hotkeys sever, i.e. where the hot keys will be run
**Detecter**: Device that handles detection of key presses & which keyboard it is and sends this to the server
## Sofware used & inspiration
Inspired by LTT editor Taran's second keyboard project: [https://github.com/TaranVH/2nd-keyboard](https://github.com/TaranVH/2nd-keyboard)
2Keys uses AutoHotkey_H (a DLL version of AutoHotkey): [https://hotkeyit.github.io/v2/](https://hotkeyit.github.io/v2/)
## License
Copyright 2018 Kishan Sambhi
2Keys is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
2Keys is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with 2Keys. If not, see .
%prep
%autosetup -n 2Keys-0.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-2Keys -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.5.1-1
- Package Spec generated