%global _empty_manifest_terminate_build 0
Name:		python-datacenter-utils
Version:	0.2.24
Release:	1
Summary:	datacenter_utils
License:	MIT
URL:		https://pypi.org/project/datacenter-utils/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/de/fd/61e7de66971c40d4a1bcf456dbf828af1db005df41cebd0b31644c27ae3c/datacenter_utils-0.2.24.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-redis
Requires:	python3-pymongo
Requires:	python3-boto3
Requires:	python3-dateutil
Requires:	python3-psycopg2-binary
Requires:	python3-pyyaml
Requires:	python3-requests

%description
# datacenter_utils

### install

```
pip install datacenter-utils
```




%package -n python3-datacenter-utils
Summary:	datacenter_utils
Provides:	python-datacenter-utils
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-datacenter-utils
# datacenter_utils

### install

```
pip install datacenter-utils
```




%package help
Summary:	Development documents and examples for datacenter-utils
Provides:	python3-datacenter-utils-doc
%description help
# datacenter_utils

### install

```
pip install datacenter-utils
```




%prep
%autosetup -n datacenter_utils-0.2.24

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-datacenter-utils -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.24-1
- Package Spec generated