%global _empty_manifest_terminate_build 0
Name:		python-ignore
Version:	0.1.4
Release:	1
Summary:	Download .gitignore files for a given language
License:	MIT
URL:		http://github.com/jarodl/ignore
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e8/25/08f7fe9dc2d5f2ee5a2676791c03f8c031815acb71f9c19247b912767dcc/ignore-0.1.4.tar.gz
BuildArch:	noarch


%description
Quickly grab common .gitignore files from the command line.
### Install
    pip install ignore
### Usage
    > ignore python
    Downloading....
    > ls -a
    .gitignore

%package -n python3-ignore
Summary:	Download .gitignore files for a given language
Provides:	python-ignore
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ignore
Quickly grab common .gitignore files from the command line.
### Install
    pip install ignore
### Usage
    > ignore python
    Downloading....
    > ls -a
    .gitignore

%package help
Summary:	Development documents and examples for ignore
Provides:	python3-ignore-doc
%description help
Quickly grab common .gitignore files from the command line.
### Install
    pip install ignore
### Usage
    > ignore python
    Downloading....
    > ls -a
    .gitignore

%prep
%autosetup -n ignore-0.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ignore -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
- Package Spec generated