%global _empty_manifest_terminate_build 0
Name:		python-chowtest
Version:	0.1.4
Release:	1
Summary:	Python implementation of the Chow test (1960).
License:	MIT License
URL:		https://github.com/David-Woroniuk/chowtest
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8a/f2/4fd589674386ed621de5661b5f55387e86503fc32e2632fd76ab4efb6f07/chowtest-0.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-sklearn
Requires:	python3-scipy

%description
# Chow Test

[![Downloads](https://pepy.tech/badge/chowtest)](https://pepy.tech/project/chowtest) [![Downloads](https://pepy.tech/badge/chowtest/month)](https://pepy.tech/project/chowtest)

This project provides an implementation of the Chow break test.

The Chow test was initially developed by Gregory Chow in 1960 to test whether one regression or two or more regressions best characterise the data. As such, the Chow test is capable of detecting "structural breaks" within time-series. Additional information can be obtained from:

[Chow, Gregory C. "Tests of equality between sets of coefficients in two linear regressions." Econometrica: Journal of the Econometric Society (1960): 591-605.][abc]

[Toyoda, Toshihisa. "Use of the Chow test under heteroscedasticity." Econometrica: Journal of the Econometric Society (1974): 601-608.][def]

This implementation supports simple linear models, and finding breaks where k = 2.

### Installation

This module requires Python 3.0+ to run. The module can can be imported by:
```python
pip install chowtest
from chow_test import chowtest
```

### Input Arguments

The required input arguments are listed below:

| Argument | Description |
| ------ | ------ |
| y | dependent variable (Pandas DataFrame Column) |
| X | independent variable(s) (Pandas Dataframe Column(s)) |
| last_index_in_model_1 | index of final point prior to assumed structural break (str) |
| first_index_in_model_2 | index of first point following structural break (str) |
| significance_level | the significance level for hypothesis testing (float)  |


   [abc]: <https://www.jstor.org/stable/1910133?casa_token=5boKBERpursAAAAA%3ABCYkFnXnHBbM0c4thWh5rySthktrt5nLlWE1nwjKbHlwmpH5fTdQoAMzgv82adNdzRzoZBe01scMcO_lDf-mjemPUsRtOmbhXkCsuoc4tUXyWrlJi59Z3Q&seq=1#metadata_info_tab_contents>
   [def]: <https://www.jstor.org/stable/1911796?casa_token=4WNFjhaMRG8AAAAA%3AKzirHep7m9iaXUTF-q90Z-ZyHVHeolvk_cNUlOuZw2bQF4z4UmAvgvejjPlC9woHSTdzBx5PVFSHP1aFhbnvWve1aMPYGO90MkbUTAgQBk-wo6HzVLjLIw&seq=1#metadata_info_tab_contents>




%package -n python3-chowtest
Summary:	Python implementation of the Chow test (1960).
Provides:	python-chowtest
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-chowtest
# Chow Test

[![Downloads](https://pepy.tech/badge/chowtest)](https://pepy.tech/project/chowtest) [![Downloads](https://pepy.tech/badge/chowtest/month)](https://pepy.tech/project/chowtest)

This project provides an implementation of the Chow break test.

The Chow test was initially developed by Gregory Chow in 1960 to test whether one regression or two or more regressions best characterise the data. As such, the Chow test is capable of detecting "structural breaks" within time-series. Additional information can be obtained from:

[Chow, Gregory C. "Tests of equality between sets of coefficients in two linear regressions." Econometrica: Journal of the Econometric Society (1960): 591-605.][abc]

[Toyoda, Toshihisa. "Use of the Chow test under heteroscedasticity." Econometrica: Journal of the Econometric Society (1974): 601-608.][def]

This implementation supports simple linear models, and finding breaks where k = 2.

### Installation

This module requires Python 3.0+ to run. The module can can be imported by:
```python
pip install chowtest
from chow_test import chowtest
```

### Input Arguments

The required input arguments are listed below:

| Argument | Description |
| ------ | ------ |
| y | dependent variable (Pandas DataFrame Column) |
| X | independent variable(s) (Pandas Dataframe Column(s)) |
| last_index_in_model_1 | index of final point prior to assumed structural break (str) |
| first_index_in_model_2 | index of first point following structural break (str) |
| significance_level | the significance level for hypothesis testing (float)  |


   [abc]: <https://www.jstor.org/stable/1910133?casa_token=5boKBERpursAAAAA%3ABCYkFnXnHBbM0c4thWh5rySthktrt5nLlWE1nwjKbHlwmpH5fTdQoAMzgv82adNdzRzoZBe01scMcO_lDf-mjemPUsRtOmbhXkCsuoc4tUXyWrlJi59Z3Q&seq=1#metadata_info_tab_contents>
   [def]: <https://www.jstor.org/stable/1911796?casa_token=4WNFjhaMRG8AAAAA%3AKzirHep7m9iaXUTF-q90Z-ZyHVHeolvk_cNUlOuZw2bQF4z4UmAvgvejjPlC9woHSTdzBx5PVFSHP1aFhbnvWve1aMPYGO90MkbUTAgQBk-wo6HzVLjLIw&seq=1#metadata_info_tab_contents>




%package help
Summary:	Development documents and examples for chowtest
Provides:	python3-chowtest-doc
%description help
# Chow Test

[![Downloads](https://pepy.tech/badge/chowtest)](https://pepy.tech/project/chowtest) [![Downloads](https://pepy.tech/badge/chowtest/month)](https://pepy.tech/project/chowtest)

This project provides an implementation of the Chow break test.

The Chow test was initially developed by Gregory Chow in 1960 to test whether one regression or two or more regressions best characterise the data. As such, the Chow test is capable of detecting "structural breaks" within time-series. Additional information can be obtained from:

[Chow, Gregory C. "Tests of equality between sets of coefficients in two linear regressions." Econometrica: Journal of the Econometric Society (1960): 591-605.][abc]

[Toyoda, Toshihisa. "Use of the Chow test under heteroscedasticity." Econometrica: Journal of the Econometric Society (1974): 601-608.][def]

This implementation supports simple linear models, and finding breaks where k = 2.

### Installation

This module requires Python 3.0+ to run. The module can can be imported by:
```python
pip install chowtest
from chow_test import chowtest
```

### Input Arguments

The required input arguments are listed below:

| Argument | Description |
| ------ | ------ |
| y | dependent variable (Pandas DataFrame Column) |
| X | independent variable(s) (Pandas Dataframe Column(s)) |
| last_index_in_model_1 | index of final point prior to assumed structural break (str) |
| first_index_in_model_2 | index of first point following structural break (str) |
| significance_level | the significance level for hypothesis testing (float)  |


   [abc]: <https://www.jstor.org/stable/1910133?casa_token=5boKBERpursAAAAA%3ABCYkFnXnHBbM0c4thWh5rySthktrt5nLlWE1nwjKbHlwmpH5fTdQoAMzgv82adNdzRzoZBe01scMcO_lDf-mjemPUsRtOmbhXkCsuoc4tUXyWrlJi59Z3Q&seq=1#metadata_info_tab_contents>
   [def]: <https://www.jstor.org/stable/1911796?casa_token=4WNFjhaMRG8AAAAA%3AKzirHep7m9iaXUTF-q90Z-ZyHVHeolvk_cNUlOuZw2bQF4z4UmAvgvejjPlC9woHSTdzBx5PVFSHP1aFhbnvWve1aMPYGO90MkbUTAgQBk-wo6HzVLjLIw&seq=1#metadata_info_tab_contents>




%prep
%autosetup -n chowtest-0.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-chowtest -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
- Package Spec generated