%global _empty_manifest_terminate_build 0
Name:		python-robotframework-angularjs
Version:	0.0.10
Release:	1
Summary:	An AngularJS extension to Robotframework's Selenium2Library
License:	Apache License 2.0
URL:		https://github.com/Selenium2Library/robotframework-angularjs
Source0:	https://mirrors.aliyun.com/pypi/web/packages/9e/ed/2b9cd0985685f808451d122ceea232f50a605302ac6055e2425287c77e70/robotframework-angularjs-0.0.10.tar.gz
BuildArch:	noarch

Requires:	python3-robotframework
Requires:	python3-robotframework-seleniumlibrary

%description
An AngularJS and Angular extension to Robotframework's SeleniumLibrary

%package -n python3-robotframework-angularjs
Summary:	An AngularJS extension to Robotframework's Selenium2Library
Provides:	python-robotframework-angularjs
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-robotframework-angularjs
An AngularJS and Angular extension to Robotframework's SeleniumLibrary

%package help
Summary:	Development documents and examples for robotframework-angularjs
Provides:	python3-robotframework-angularjs-doc
%description help
An AngularJS and Angular extension to Robotframework's SeleniumLibrary

%prep
%autosetup -n robotframework-angularjs-0.0.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-robotframework-angularjs -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.10-1
- Package Spec generated