%global _empty_manifest_terminate_build 0
Name: python-icevision
Version: 0.12.0
Release: 1
Summary: Agnostic Computer Vision Framework
License: Apache-2.0
URL: https://pypi.org/project/icevision/
Source0: https://mirrors.aliyun.com/pypi/web/packages/07/09/540d089cacba6f62efd6f0ee3e216b5f3ff598a10f85b1eeb76f171e18ee/icevision-0.12.0.tar.gz
BuildArch: noarch
Requires: python3-pillow
Requires: python3-torch
Requires: python3-torchvision
Requires: python3-fastcore
Requires: python3-tqdm
Requires: python3-opencv-python
Requires: python3-albumentations
Requires: python3-resnest
Requires: python3-effdet
Requires: python3-sahi
Requires: python3-yolov5-icevision
Requires: python3-ipykernel
Requires: python3-dataclasses
Requires: python3-loguru
Requires: python3-importlib-metadata
Requires: python3-fastai
Requires: python3-pytorch-lightning
Requires: python3-wandb
Requires: python3-icevision[all]
Requires: python3-keras-autodoc
Requires: python3-black
Requires: python3-pytest
Requires: python3-mkdocs
Requires: python3-mkdocs-material
Requires: python3-mike
Requires: python3-jupyter
Requires: python3-Sphinx
Requires: python3-pytest-cov
Requires: python3-flake8
Requires: python3-pre-commit
Requires: python3-pytest-mock
Requires: python3-icevision
%description
An Agnostic Object Detection Framework
* * * * *
[![tests](https://github.com/airctic/icevision/workflows/tests/badge.svg?event=push)](https://github.com/airctic/icevision/actions?query=workflow%3Atests)
[![docs](https://github.com/airctic/icevision/workflows/docs/badge.svg)](https://airctic.com)
[![codecov](https://codecov.io/gh/airctic/icevision/branch/master/graph/badge.svg)](https://codecov.io/gh/airctic/icevision)
[![PyPI version](https://badge.fury.io/py/icevision.svg)](https://badge.fury.io/py/icevision)
[![Downloads](https://pepy.tech/badge/icevision)](https://pepy.tech/project/icevision)
[![black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/airctic/icevision/blob/master/LICENSE)
[![Discord](https://img.shields.io/discord/735877944085446747?label=Discord&logo=Discord)](https://discord.gg/2jqrwrQ)
* * * * *
IceVision is the first agnostic computer vision framework to offer a curated collection with hundreds of high-quality pre-trained models from torchvision, MMLabs, and soon Pytorch Image Models. It orchestrates the end-to-end deep learning workflow allowing to train networks with easy-to-use robust high-performance libraries such as Pytorch-Lightning and Fastai
**IceVision Unique Features:**
- Data curation/cleaning with auto-fix
- Access to an exploratory data analysis dashboard
- Pluggable transforms for better model generalization
- Access to hundreds of neural net models
- Access to multiple training loop libraries
- Multi-task training to efficiently combine object detection, segmentation, and classification models
## Installation
```bash
pip install icevision[all]
```
For more installation options, check our [docs](https://airctic.com/0.7.0/install/).
**Important:** We currently only support Linux/MacOS.
## Quick Example: How to train the **Fridge Objects Dataset**
![image](images/icevision-readme.png)
![image](images/icevision-end-to-end-training.gif)
## Happy Learning!
If you need any assistance, feel free to:
[Join our Forum](https://discord.gg/JDBeZYK)
%package -n python3-icevision
Summary: Agnostic Computer Vision Framework
Provides: python-icevision
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-icevision
An Agnostic Object Detection Framework
* * * * *
[![tests](https://github.com/airctic/icevision/workflows/tests/badge.svg?event=push)](https://github.com/airctic/icevision/actions?query=workflow%3Atests)
[![docs](https://github.com/airctic/icevision/workflows/docs/badge.svg)](https://airctic.com)
[![codecov](https://codecov.io/gh/airctic/icevision/branch/master/graph/badge.svg)](https://codecov.io/gh/airctic/icevision)
[![PyPI version](https://badge.fury.io/py/icevision.svg)](https://badge.fury.io/py/icevision)
[![Downloads](https://pepy.tech/badge/icevision)](https://pepy.tech/project/icevision)
[![black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/airctic/icevision/blob/master/LICENSE)
[![Discord](https://img.shields.io/discord/735877944085446747?label=Discord&logo=Discord)](https://discord.gg/2jqrwrQ)
* * * * *
IceVision is the first agnostic computer vision framework to offer a curated collection with hundreds of high-quality pre-trained models from torchvision, MMLabs, and soon Pytorch Image Models. It orchestrates the end-to-end deep learning workflow allowing to train networks with easy-to-use robust high-performance libraries such as Pytorch-Lightning and Fastai
**IceVision Unique Features:**
- Data curation/cleaning with auto-fix
- Access to an exploratory data analysis dashboard
- Pluggable transforms for better model generalization
- Access to hundreds of neural net models
- Access to multiple training loop libraries
- Multi-task training to efficiently combine object detection, segmentation, and classification models
## Installation
```bash
pip install icevision[all]
```
For more installation options, check our [docs](https://airctic.com/0.7.0/install/).
**Important:** We currently only support Linux/MacOS.
## Quick Example: How to train the **Fridge Objects Dataset**
![image](images/icevision-readme.png)
![image](images/icevision-end-to-end-training.gif)
## Happy Learning!
If you need any assistance, feel free to:
[Join our Forum](https://discord.gg/JDBeZYK)
%package help
Summary: Development documents and examples for icevision
Provides: python3-icevision-doc
%description help
An Agnostic Object Detection Framework
* * * * *
[![tests](https://github.com/airctic/icevision/workflows/tests/badge.svg?event=push)](https://github.com/airctic/icevision/actions?query=workflow%3Atests)
[![docs](https://github.com/airctic/icevision/workflows/docs/badge.svg)](https://airctic.com)
[![codecov](https://codecov.io/gh/airctic/icevision/branch/master/graph/badge.svg)](https://codecov.io/gh/airctic/icevision)
[![PyPI version](https://badge.fury.io/py/icevision.svg)](https://badge.fury.io/py/icevision)
[![Downloads](https://pepy.tech/badge/icevision)](https://pepy.tech/project/icevision)
[![black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![license](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/airctic/icevision/blob/master/LICENSE)
[![Discord](https://img.shields.io/discord/735877944085446747?label=Discord&logo=Discord)](https://discord.gg/2jqrwrQ)
* * * * *
IceVision is the first agnostic computer vision framework to offer a curated collection with hundreds of high-quality pre-trained models from torchvision, MMLabs, and soon Pytorch Image Models. It orchestrates the end-to-end deep learning workflow allowing to train networks with easy-to-use robust high-performance libraries such as Pytorch-Lightning and Fastai
**IceVision Unique Features:**
- Data curation/cleaning with auto-fix
- Access to an exploratory data analysis dashboard
- Pluggable transforms for better model generalization
- Access to hundreds of neural net models
- Access to multiple training loop libraries
- Multi-task training to efficiently combine object detection, segmentation, and classification models
## Installation
```bash
pip install icevision[all]
```
For more installation options, check our [docs](https://airctic.com/0.7.0/install/).
**Important:** We currently only support Linux/MacOS.
## Quick Example: How to train the **Fridge Objects Dataset**
![image](images/icevision-readme.png)
![image](images/icevision-end-to-end-training.gif)
## Happy Learning!
If you need any assistance, feel free to:
[Join our Forum](https://discord.gg/JDBeZYK)
%prep
%autosetup -n icevision-0.12.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-icevision -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.12.0-1
- Package Spec generated