%global _empty_manifest_terminate_build 0
Name:		python-pyobihai
Version:	1.4.1
Release:	1
Summary:	A Python wrapper for Obihai
License:	MIT
URL:		https://github.com/ejpenney/pyobihai
Source0:	https://mirrors.aliyun.com/pypi/web/packages/20/72/36f2efd582e812bfd9a942918a9405eb8b861894e90600f5a62821adde93/pyobihai-1.4.1.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-defusedxml

%description
# pyobihai

Python wrapper to grab call status from Obihai devices for Home Assistant.

Forked from https://github.com/dshokouhi/pyobihai (No longer maintained)

Thanks to https://github.com/sogood007/home-assistant-obihai and https://github.com/scadagenius/obisyslog for most of the code.


%package -n python3-pyobihai
Summary:	A Python wrapper for Obihai
Provides:	python-pyobihai
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyobihai
# pyobihai

Python wrapper to grab call status from Obihai devices for Home Assistant.

Forked from https://github.com/dshokouhi/pyobihai (No longer maintained)

Thanks to https://github.com/sogood007/home-assistant-obihai and https://github.com/scadagenius/obisyslog for most of the code.


%package help
Summary:	Development documents and examples for pyobihai
Provides:	python3-pyobihai-doc
%description help
# pyobihai

Python wrapper to grab call status from Obihai devices for Home Assistant.

Forked from https://github.com/dshokouhi/pyobihai (No longer maintained)

Thanks to https://github.com/sogood007/home-assistant-obihai and https://github.com/scadagenius/obisyslog for most of the code.


%prep
%autosetup -n pyobihai-1.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyobihai -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.1-1
- Package Spec generated