%global _empty_manifest_terminate_build 0
Name:		python-gsdl
Version:	1.0.6
Release:	1
Summary:	Pygame GUI Library.
License:	MIT
URL:		https://github.com/Pixelsuft/gsdl
Source0:	https://mirrors.aliyun.com/pypi/web/packages/3f/91/f07c2575c16a85cd34c734ca340272eb6ee40fe3f0c35cf397d1b73cee1e/gsdl-1.0.6.tar.gz
BuildArch:	noarch

Requires:	python3-pygame
Requires:	python3-Pillow
Requires:	python3-buildozer

%description
# GSDL
Python GUI lib for PyGame
## Links
[Github](https://github.com/Pixelsuft/gsdl) <br />
[PyPi](https://pypi.org/project/gsdl/) <br />
[Example](https://github.com/Pixelsuft/gsdl/blob/main/main.py) <br />
[Issue Tracker](https://github.com/Pixelsuft/gsdl/issues)
## Work In Progress




%package -n python3-gsdl
Summary:	Pygame GUI Library.
Provides:	python-gsdl
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-gsdl
# GSDL
Python GUI lib for PyGame
## Links
[Github](https://github.com/Pixelsuft/gsdl) <br />
[PyPi](https://pypi.org/project/gsdl/) <br />
[Example](https://github.com/Pixelsuft/gsdl/blob/main/main.py) <br />
[Issue Tracker](https://github.com/Pixelsuft/gsdl/issues)
## Work In Progress




%package help
Summary:	Development documents and examples for gsdl
Provides:	python3-gsdl-doc
%description help
# GSDL
Python GUI lib for PyGame
## Links
[Github](https://github.com/Pixelsuft/gsdl) <br />
[PyPi](https://pypi.org/project/gsdl/) <br />
[Example](https://github.com/Pixelsuft/gsdl/blob/main/main.py) <br />
[Issue Tracker](https://github.com/Pixelsuft/gsdl/issues)
## Work In Progress




%prep
%autosetup -n gsdl-1.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-gsdl -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.6-1
- Package Spec generated