%global _empty_manifest_terminate_build 0 Name: python-pocard Version: 0.0.7 Release: 1 Summary: PokemonCard Generator License: MIT URL: https://github.com/krypton-byte/pocard Source0: https://mirrors.aliyun.com/pypi/web/packages/56/a4/827dfe19afa8b4cff39677ed3b3eb03230083ec517ae60c380ebbefa7423/pocard-0.0.7.tar.gz BuildArch: noarch %description
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview