%global _empty_manifest_terminate_build 0
Name: python-adafruit-circuitpython-ssd1306
Version: 2.12.13
Release: 1
Summary: CircuitPython library for SSD1306 OLED displays.
License: MIT
URL: https://github.com/adafruit/Adafruit_CircuitPython_SSD1306
Source0: https://mirrors.aliyun.com/pypi/web/packages/80/d1/3bc07146ea471faf02e5bf71d1885974f5ca8ce56bfeb4d18b622716b966/adafruit-circuitpython-ssd1306-2.12.13.tar.gz
BuildArch: noarch
Requires: python3-Adafruit-Blinka
Requires: python3-adafruit-circuitpython-busdevice
Requires: python3-adafruit-circuitpython-framebuf
%description
Adafruit CircuitPython driver for SSD1306 or SSD1305 OLED displays. Note that SSD1305 displays are back compatible so they can be used in-place of SSD1306 with the same code and commands.
This driver implements the `adafruit_framebuf interface `__. It is **not** the `displayio` driver for the SSD1306. See the `Adafruit CircuitPython DisplayIO SSD1306 `_ driver for `displayio` support.
%package -n python3-adafruit-circuitpython-ssd1306
Summary: CircuitPython library for SSD1306 OLED displays.
Provides: python-adafruit-circuitpython-ssd1306
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-adafruit-circuitpython-ssd1306
Adafruit CircuitPython driver for SSD1306 or SSD1305 OLED displays. Note that SSD1305 displays are back compatible so they can be used in-place of SSD1306 with the same code and commands.
This driver implements the `adafruit_framebuf interface `__. It is **not** the `displayio` driver for the SSD1306. See the `Adafruit CircuitPython DisplayIO SSD1306 `_ driver for `displayio` support.
%package help
Summary: Development documents and examples for adafruit-circuitpython-ssd1306
Provides: python3-adafruit-circuitpython-ssd1306-doc
%description help
Adafruit CircuitPython driver for SSD1306 or SSD1305 OLED displays. Note that SSD1305 displays are back compatible so they can be used in-place of SSD1306 with the same code and commands.
This driver implements the `adafruit_framebuf interface `__. It is **not** the `displayio` driver for the SSD1306. See the `Adafruit CircuitPython DisplayIO SSD1306 `_ driver for `displayio` support.
%prep
%autosetup -n adafruit-circuitpython-ssd1306-2.12.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-adafruit-circuitpython-ssd1306 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.12.13-1
- Package Spec generated