%global _empty_manifest_terminate_build 0
Name:		python-vice
Version:	1.3.0
Release:	1
Summary:	Galactic Chemical Evolution Integrator
License:	MIT
URL:		https://github.com/giganano/VICE.git
Source0:	https://mirrors.aliyun.com/pypi/web/packages/aa/9e/adf3556301cfd3ff73414718ccd83322c3c53a108f02f3fc9a51f8115ad1/vice-1.3.0.tar.gz
BuildArch:	noarch


%description
Documentation is available in several forms:
	1. Online: http://vice-astro.readthedocs.io
	2. In PDF format, available for download at the same address
	3. In the docstrings embedded within the software
Running ``vice --docs`` from the terminal will open the online documentation
in the default web browser.
First time users should go through VICE's QuickStartTutorial jupyter notebook,
available under examples/ in the git repository. This can be launched from
the command line by running ``vice --tutorial``. Other example scripts can
be found there as well.

%package -n python3-vice
Summary:	Galactic Chemical Evolution Integrator
Provides:	python-vice
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vice
Documentation is available in several forms:
	1. Online: http://vice-astro.readthedocs.io
	2. In PDF format, available for download at the same address
	3. In the docstrings embedded within the software
Running ``vice --docs`` from the terminal will open the online documentation
in the default web browser.
First time users should go through VICE's QuickStartTutorial jupyter notebook,
available under examples/ in the git repository. This can be launched from
the command line by running ``vice --tutorial``. Other example scripts can
be found there as well.

%package help
Summary:	Development documents and examples for vice
Provides:	python3-vice-doc
%description help
Documentation is available in several forms:
	1. Online: http://vice-astro.readthedocs.io
	2. In PDF format, available for download at the same address
	3. In the docstrings embedded within the software
Running ``vice --docs`` from the terminal will open the online documentation
in the default web browser.
First time users should go through VICE's QuickStartTutorial jupyter notebook,
available under examples/ in the git repository. This can be launched from
the command line by running ``vice --tutorial``. Other example scripts can
be found there as well.

%prep
%autosetup -n vice-1.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vice -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
- Package Spec generated