%global _empty_manifest_terminate_build 0
Name:		python-Orange-Textable
Version:	2.0.1
Release:	1
Summary:	Textable add-on for Orange 2.7 data mining software package.
License:	GPLv3
URL:		http://langtech.ch/textable
Source0:	https://mirrors.aliyun.com/pypi/web/packages/a9/2f/d63f34a4156106d58bbb3f3437ba50ba3517cfc202e8d1f9fec4fcac37f3/Orange-Textable-2.0.1.tar.gz
BuildArch:	noarch


%description
Orange Textable is an open-source add-on bringing advanced text-analytical
functionalities to the `Orange Canvas <http://orange.biolab.si/>`_ data mining
software package (itself open-source). It essentially enables users to build
data tables on the basis of text data, by means of a flexible and intuitive
interface. Look at the following `example
<http://orange-textable.readthedocs.org/en/latest/illustration.html>`_ to see
it in typical action.
Orange Textable offers in particular the following features:
* text data import from keyboard, files, or urls
* support for various encodings, including Unicode
* standard preprocessing and custom recoding (based on regular expressions)
* segmentation and annotation of various text units (letters, words, etc.)
* ability to extract and exploit XML-encoded annotations
* automatic, random, or arbitrary selection of unit subsets
* unit context examination using concordance and collocation tables
* calculation of frequency and complexity measures
* recoded text data and table export
The project's homepage is http://langtech.ch/textable
Documentation is hosted at: http://orange-textable.readthedocs.org/
Orange Textable was designed and implemented by `LangTech Sarl
<http://langtech.ch>`_ on behalf of the `department of language and
information sciences (SLI) <http://www.unil.ch/sli>`_ at the `University of
Lausanne <http://www.unil.ch>`_ (see `Credits
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_ and
`How to cite Orange Textable
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_).

%package -n python3-Orange-Textable
Summary:	Textable add-on for Orange 2.7 data mining software package.
Provides:	python-Orange-Textable
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Orange-Textable
Orange Textable is an open-source add-on bringing advanced text-analytical
functionalities to the `Orange Canvas <http://orange.biolab.si/>`_ data mining
software package (itself open-source). It essentially enables users to build
data tables on the basis of text data, by means of a flexible and intuitive
interface. Look at the following `example
<http://orange-textable.readthedocs.org/en/latest/illustration.html>`_ to see
it in typical action.
Orange Textable offers in particular the following features:
* text data import from keyboard, files, or urls
* support for various encodings, including Unicode
* standard preprocessing and custom recoding (based on regular expressions)
* segmentation and annotation of various text units (letters, words, etc.)
* ability to extract and exploit XML-encoded annotations
* automatic, random, or arbitrary selection of unit subsets
* unit context examination using concordance and collocation tables
* calculation of frequency and complexity measures
* recoded text data and table export
The project's homepage is http://langtech.ch/textable
Documentation is hosted at: http://orange-textable.readthedocs.org/
Orange Textable was designed and implemented by `LangTech Sarl
<http://langtech.ch>`_ on behalf of the `department of language and
information sciences (SLI) <http://www.unil.ch/sli>`_ at the `University of
Lausanne <http://www.unil.ch>`_ (see `Credits
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_ and
`How to cite Orange Textable
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_).

%package help
Summary:	Development documents and examples for Orange-Textable
Provides:	python3-Orange-Textable-doc
%description help
Orange Textable is an open-source add-on bringing advanced text-analytical
functionalities to the `Orange Canvas <http://orange.biolab.si/>`_ data mining
software package (itself open-source). It essentially enables users to build
data tables on the basis of text data, by means of a flexible and intuitive
interface. Look at the following `example
<http://orange-textable.readthedocs.org/en/latest/illustration.html>`_ to see
it in typical action.
Orange Textable offers in particular the following features:
* text data import from keyboard, files, or urls
* support for various encodings, including Unicode
* standard preprocessing and custom recoding (based on regular expressions)
* segmentation and annotation of various text units (letters, words, etc.)
* ability to extract and exploit XML-encoded annotations
* automatic, random, or arbitrary selection of unit subsets
* unit context examination using concordance and collocation tables
* calculation of frequency and complexity measures
* recoded text data and table export
The project's homepage is http://langtech.ch/textable
Documentation is hosted at: http://orange-textable.readthedocs.org/
Orange Textable was designed and implemented by `LangTech Sarl
<http://langtech.ch>`_ on behalf of the `department of language and
information sciences (SLI) <http://www.unil.ch/sli>`_ at the `University of
Lausanne <http://www.unil.ch>`_ (see `Credits
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_ and
`How to cite Orange Textable
<http://orange-textable.readthedocs.io/en/latest/credits.html>`_).

%prep
%autosetup -n Orange-Textable-2.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Orange-Textable -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
- Package Spec generated