%global _empty_manifest_terminate_build 0 Name: python-pyteledantic Version: 0.0.16 Release: 1 Summary: Pydantic models for Telegram Bot API License: MIT License URL: https://github.com/isys35/pyteledantic Source0: https://mirrors.aliyun.com/pypi/web/packages/5f/5d/e83840073c7a55cbc44efc6c088f72fb4ea6a2a17505968577a29176735c/pyteledantic-0.0.16.tar.gz BuildArch: noarch Requires: python3-pydantic Requires: python3-typing-extensions Requires: python3-types-requests Requires: python3-types-urllib3 Requires: python3-requests %description

Pydantic models for Telegram Bot API

Install: ```pip install pyteledantic```

How to use

FastAPI

````python from fastapi import FastAPI from pyteledantic.models import Update app = FastAPI() @app.post("/") async def root(update: Update): return update ```` %package -n python3-pyteledantic Summary: Pydantic models for Telegram Bot API Provides: python-pyteledantic BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pyteledantic

Pydantic models for Telegram Bot API

Install: ```pip install pyteledantic```

How to use

FastAPI

````python from fastapi import FastAPI from pyteledantic.models import Update app = FastAPI() @app.post("/") async def root(update: Update): return update ```` %package help Summary: Development documents and examples for pyteledantic Provides: python3-pyteledantic-doc %description help

Pydantic models for Telegram Bot API

Install: ```pip install pyteledantic```

How to use

FastAPI

````python from fastapi import FastAPI from pyteledantic.models import Update app = FastAPI() @app.post("/") async def root(update: Update): return update ```` %prep %autosetup -n pyteledantic-0.0.16 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pyteledantic -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 0.0.16-1 - Package Spec generated