%global _empty_manifest_terminate_build 0
Name:		python-InowasFlopyAdapter
Version:	1.5.0
Release:	1
Summary:	A FLOPY wrapper for the INOWAS-platform
License:	MIT License
URL:		https://github.com/inowas/InowasFlopyAdapter
Source0:	https://mirrors.aliyun.com/pypi/web/packages/8b/de/20cf6faec695f35a0b6c58d00e8859e4ef8fe92e8c96ac7deba2aebf2c98/InowasFlopyAdapter-1.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-flopy
Requires:	python3-geojson
Requires:	python3-nose
Requires:	python3-numpy
Requires:	python3-pyproj
Requires:	python3-rasterio
Requires:	python3-scipy
Requires:	python3-shapely
Requires:	python3-sklearn
Requires:	python3-setuptools
Requires:	python3-twine
Requires:	python3-utm

%description
# InowasFlopyAdapter

This library is used as a Flopy-Wrapper on the INOWAS-Platform.

More information will follow shortly.

## For developers

1. clone this
2. create a new environment
3. run `pip install .` to get all packages installed


## Run tests

There is a makefile provided to run the tests






%package -n python3-InowasFlopyAdapter
Summary:	A FLOPY wrapper for the INOWAS-platform
Provides:	python-InowasFlopyAdapter
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-InowasFlopyAdapter
# InowasFlopyAdapter

This library is used as a Flopy-Wrapper on the INOWAS-Platform.

More information will follow shortly.

## For developers

1. clone this
2. create a new environment
3. run `pip install .` to get all packages installed


## Run tests

There is a makefile provided to run the tests






%package help
Summary:	Development documents and examples for InowasFlopyAdapter
Provides:	python3-InowasFlopyAdapter-doc
%description help
# InowasFlopyAdapter

This library is used as a Flopy-Wrapper on the INOWAS-Platform.

More information will follow shortly.

## For developers

1. clone this
2. create a new environment
3. run `pip install .` to get all packages installed


## Run tests

There is a makefile provided to run the tests






%prep
%autosetup -n InowasFlopyAdapter-1.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-InowasFlopyAdapter -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.0-1
- Package Spec generated