%global _empty_manifest_terminate_build 0
Name:		python-terrascript
Version:	0.9.0
Release:	1
Summary:	Python module for creating Terraform configurations
License:	BSD 2-clause "Simplified" License
URL:		https://github.com/mjuenema/python-terrascript
Source0:	https://mirrors.aliyun.com/pypi/web/packages/83/14/a45bf668e0413167538adffac85d2b58b7ea7c209fc9fed5d30ad1948e01/terrascript-0.9.0.tar.gz
BuildArch:	noarch


%description
Looking for more contributors
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IF you feel that this project is useful to you, please consider contributing some of your time towards improving it!
For more details on contributions, please have a look at CONTRIBUTORS.md and DEVELOPMENT.md.
About 
~~~~~
Python-Terrascript is a Python package for generating Terraform configurations in JSON format.
Creating Terraform through a Python script offers a degree of flexibility 
superior to writing Terraform configurations by hand.
* Control structures like ``if``/``else``, ``for``/``continue``/``break`` or ``try``/``except``/``finally``.
* More string methods.
* Python functions may be used as an alternative to Terraform Modules.
* Access to the Python Standard Library and third-party packages.
Compatibility
~~~~~~~~~~~~~
Terraform releases
`Terraform 0.12` introduced some changes to how it deals with configuration 
files in JSON format. This is reflected in Terrascript by currently having
separate releases for Terraform 0.12 and Terraform 0.11. Earlier releases of 

%package -n python3-terrascript
Summary:	Python module for creating Terraform configurations
Provides:	python-terrascript
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-terrascript
Looking for more contributors
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IF you feel that this project is useful to you, please consider contributing some of your time towards improving it!
For more details on contributions, please have a look at CONTRIBUTORS.md and DEVELOPMENT.md.
About 
~~~~~
Python-Terrascript is a Python package for generating Terraform configurations in JSON format.
Creating Terraform through a Python script offers a degree of flexibility 
superior to writing Terraform configurations by hand.
* Control structures like ``if``/``else``, ``for``/``continue``/``break`` or ``try``/``except``/``finally``.
* More string methods.
* Python functions may be used as an alternative to Terraform Modules.
* Access to the Python Standard Library and third-party packages.
Compatibility
~~~~~~~~~~~~~
Terraform releases
`Terraform 0.12` introduced some changes to how it deals with configuration 
files in JSON format. This is reflected in Terrascript by currently having
separate releases for Terraform 0.12 and Terraform 0.11. Earlier releases of 

%package help
Summary:	Development documents and examples for terrascript
Provides:	python3-terrascript-doc
%description help
Looking for more contributors
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
IF you feel that this project is useful to you, please consider contributing some of your time towards improving it!
For more details on contributions, please have a look at CONTRIBUTORS.md and DEVELOPMENT.md.
About 
~~~~~
Python-Terrascript is a Python package for generating Terraform configurations in JSON format.
Creating Terraform through a Python script offers a degree of flexibility 
superior to writing Terraform configurations by hand.
* Control structures like ``if``/``else``, ``for``/``continue``/``break`` or ``try``/``except``/``finally``.
* More string methods.
* Python functions may be used as an alternative to Terraform Modules.
* Access to the Python Standard Library and third-party packages.
Compatibility
~~~~~~~~~~~~~
Terraform releases
`Terraform 0.12` introduced some changes to how it deals with configuration 
files in JSON format. This is reflected in Terrascript by currently having
separate releases for Terraform 0.12 and Terraform 0.11. Earlier releases of 

%prep
%autosetup -n terrascript-0.9.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-terrascript -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
- Package Spec generated