%global _empty_manifest_terminate_build 0
Name: python-wfetch
Version: 0.1.2
Release: 1
Summary: Minimal Windows system information tool written in Python
License: MIT License
URL: https://github.com/zJairO/wfetch
Source0: https://mirrors.aliyun.com/pypi/web/packages/a8/46/9251e055ec0359d5b2230e61a2fddc915481d58ff3ad57287442ac67a364/wfetch-0.1.2.tar.gz
BuildArch: noarch
%description
# wfetch
![](https://repository-images.githubusercontent.com/428005882/372e59fc-61bb-4dcb-acfd-44151f830c16)
wfetch is a Minimal Windows system information tool written in Python (Only works on Windows)
## Installation
First of all have python installed.
https://www.python.org/
Then install MesloLGS NF Fonts:
- [MesloLGS NF Regular.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Regular.ttf)
- [MesloLGS NF Bold.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold.ttf)
- [MesloLGS NF Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Italic.ttf)
- [MesloLGS NF Bold Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold%20Italic.ttf)
I use font size 11.
Use Windows Terminal.
```bash
pip install wfetch
```
## Usage
```bash
wfetch
```
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
Please make sure to update tests as appropriate.
## License
[MIT](https://choosealicense.com/licenses/mit/)
## Buy Me a Coffee
%package -n python3-wfetch
Summary: Minimal Windows system information tool written in Python
Provides: python-wfetch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wfetch
# wfetch
![](https://repository-images.githubusercontent.com/428005882/372e59fc-61bb-4dcb-acfd-44151f830c16)
wfetch is a Minimal Windows system information tool written in Python (Only works on Windows)
## Installation
First of all have python installed.
https://www.python.org/
Then install MesloLGS NF Fonts:
- [MesloLGS NF Regular.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Regular.ttf)
- [MesloLGS NF Bold.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold.ttf)
- [MesloLGS NF Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Italic.ttf)
- [MesloLGS NF Bold Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold%20Italic.ttf)
I use font size 11.
Use Windows Terminal.
```bash
pip install wfetch
```
## Usage
```bash
wfetch
```
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
Please make sure to update tests as appropriate.
## License
[MIT](https://choosealicense.com/licenses/mit/)
## Buy Me a Coffee
%package help
Summary: Development documents and examples for wfetch
Provides: python3-wfetch-doc
%description help
# wfetch
![](https://repository-images.githubusercontent.com/428005882/372e59fc-61bb-4dcb-acfd-44151f830c16)
wfetch is a Minimal Windows system information tool written in Python (Only works on Windows)
## Installation
First of all have python installed.
https://www.python.org/
Then install MesloLGS NF Fonts:
- [MesloLGS NF Regular.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Regular.ttf)
- [MesloLGS NF Bold.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold.ttf)
- [MesloLGS NF Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Italic.ttf)
- [MesloLGS NF Bold Italic.ttf](
https://github.com/romkatv/powerlevel10k-media/raw/master/MesloLGS%20NF%20Bold%20Italic.ttf)
I use font size 11.
Use Windows Terminal.
```bash
pip install wfetch
```
## Usage
```bash
wfetch
```
## Contributing
Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.
Please make sure to update tests as appropriate.
## License
[MIT](https://choosealicense.com/licenses/mit/)
## Buy Me a Coffee
%prep
%autosetup -n wfetch-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wfetch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.2-1
- Package Spec generated