%global _empty_manifest_terminate_build 0
Name:		python-google-cloud-artifact-registry
Version:	1.8.1
Release:	1
Summary:	Google Cloud Artifact Registry API client library
License:	Apache 2.0
URL:		https://github.com/googleapis/python-artifact-registry
Source0:	https://mirrors.aliyun.com/pypi/web/packages/84/d8/42b29f72e6fb5dc086a12f31413a25abba2d41db2d30983fec85788ae018/google-cloud-artifact-registry-1.8.1.tar.gz
BuildArch:	noarch

Requires:	python3-google-api-core[grpc]
Requires:	python3-proto-plus
Requires:	python3-protobuf
Requires:	python3-grpc-google-iam-v1
Requires:	python3-proto-plus

%description
|stable| |pypi| |versions|
`Artifact Registry API`_: provides a single place for your organization to manage container images and language packages (such as Maven and npm). It is fully integrated with Google Cloud's tooling and runtimes and comes with support for native artifact protocols. This makes it simple to integrate it with your CI/CD tooling to set up automated pipelines.
- `Client Library Documentation`_
- `Product Documentation`_

%package -n python3-google-cloud-artifact-registry
Summary:	Google Cloud Artifact Registry API client library
Provides:	python-google-cloud-artifact-registry
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-google-cloud-artifact-registry
|stable| |pypi| |versions|
`Artifact Registry API`_: provides a single place for your organization to manage container images and language packages (such as Maven and npm). It is fully integrated with Google Cloud's tooling and runtimes and comes with support for native artifact protocols. This makes it simple to integrate it with your CI/CD tooling to set up automated pipelines.
- `Client Library Documentation`_
- `Product Documentation`_

%package help
Summary:	Development documents and examples for google-cloud-artifact-registry
Provides:	python3-google-cloud-artifact-registry-doc
%description help
|stable| |pypi| |versions|
`Artifact Registry API`_: provides a single place for your organization to manage container images and language packages (such as Maven and npm). It is fully integrated with Google Cloud's tooling and runtimes and comes with support for native artifact protocols. This makes it simple to integrate it with your CI/CD tooling to set up automated pipelines.
- `Client Library Documentation`_
- `Product Documentation`_

%prep
%autosetup -n google-cloud-artifact-registry-1.8.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-google-cloud-artifact-registry -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8.1-1
- Package Spec generated