%global _empty_manifest_terminate_build 0
Name:		python-pywayland
Version:	0.4.15
Release:	1
Summary:	Python bindings for the libwayland library written in pure Python
License:	Apache License 2.0
URL:		https://github.com/flacjacket/pywayland
Source0:	https://mirrors.aliyun.com/pypi/web/packages/f8/39/a6193ccdd53bc732ef526810ba07241122b2b89e4d1ec4cb120dd3ca5dfc/pywayland-0.4.15.tar.gz
BuildArch:	noarch

Requires:	python3-cffi

%description
Built against Wayland 1.21.0
|ci| |coveralls| |docs|
PyWayland provides a wrapper to the ``libwayland`` library using the CFFI
library to provide access to the Wayland library calls and written in pure
Python.
Below is outlined some of the basics of PyWayland and how to get up and
running.  For more help, see the `full documentation`_.

%package -n python3-pywayland
Summary:	Python bindings for the libwayland library written in pure Python
Provides:	python-pywayland
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pywayland
Built against Wayland 1.21.0
|ci| |coveralls| |docs|
PyWayland provides a wrapper to the ``libwayland`` library using the CFFI
library to provide access to the Wayland library calls and written in pure
Python.
Below is outlined some of the basics of PyWayland and how to get up and
running.  For more help, see the `full documentation`_.

%package help
Summary:	Development documents and examples for pywayland
Provides:	python3-pywayland-doc
%description help
Built against Wayland 1.21.0
|ci| |coveralls| |docs|
PyWayland provides a wrapper to the ``libwayland`` library using the CFFI
library to provide access to the Wayland library calls and written in pure
Python.
Below is outlined some of the basics of PyWayland and how to get up and
running.  For more help, see the `full documentation`_.

%prep
%autosetup -n pywayland-0.4.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pywayland -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.15-1
- Package Spec generated