%global _empty_manifest_terminate_build 0
Name: python-eodag
Version: 2.10.0
Release: 1
Summary: Earth Observation Data Access Gateway
License: Apache 2.0
URL: https://github.com/CS-SI/eodag
Source0: https://mirrors.aliyun.com/pypi/web/packages/75/82/53b4a20031e7bb965d836c7ed68a2d7e35b4f091bf09e51b943d4a0fc851/eodag-2.10.0.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-requests
Requires: python3-dateutil
Requires: python3-PyYAML
Requires: python3-tqdm
Requires: python3-shapely
Requires: python3-pyshp
Requires: python3-orjson
Requires: python3-geojson
Requires: python3-pyproj
Requires: python3-usgs
Requires: python3-boto3
Requires: python3-flasgger
Requires: python3-jsonpath-ng
Requires: python3-lxml
Requires: python3-flask
Requires: python3-whoosh
Requires: python3-pystac
Requires: python3-ecmwf-api-client
Requires: python3-cdsapi
Requires: python3-owslib
Requires: python3-owslib
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-py
Requires: python3-pytest-html
Requires: python3-pytest-xdist
Requires: python3-pytest-socket
Requires: python3-pytest-instafail
Requires: python3-tox
Requires: python3-faker
Requires: python3-moto
Requires: python3-twine
Requires: python3-wheel
Requires: python3-flake8
Requires: python3-pre-commit
Requires: python3-responses
Requires: python3-sphinx
Requires: python3-sphinx-book-theme
Requires: python3-sphinx-copybutton
Requires: python3-sphinxcontrib-jquery
Requires: python3-nbsphinx
Requires: python3-ipython
Requires: python3-tqdm[notebook]
Requires: python3-eodag-cube
Requires: python3-jupyter
Requires: python3-ipyleaflet
Requires: python3-ipywidgets
Requires: python3-matplotlib
Requires: python3-folium
Requires: python3-imageio
Requires: python3-rasterio
Requires: python3-netcdf4
%description
EODAG is available on `PyPI `_:
python -m pip install eodag
And with ``conda`` from the `conda-forge channel `_:
conda install -c conda-forge eodag
%package -n python3-eodag
Summary: Earth Observation Data Access Gateway
Provides: python-eodag
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-eodag
EODAG is available on `PyPI `_:
python -m pip install eodag
And with ``conda`` from the `conda-forge channel `_:
conda install -c conda-forge eodag
%package help
Summary: Development documents and examples for eodag
Provides: python3-eodag-doc
%description help
EODAG is available on `PyPI `_:
python -m pip install eodag
And with ``conda`` from the `conda-forge channel `_:
conda install -c conda-forge eodag
%prep
%autosetup -n eodag-2.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-eodag -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.10.0-1
- Package Spec generated