%global _empty_manifest_terminate_build 0
Name: python-make-responsive-images
Version: 0.1.11
Release: 1
Summary: Generate responsive images for your website, so you can use srcset in your tags and serve an optimal image to each device that views your site.
License: MIT
URL: https://mccarthysean.dev/make-responsive-images
Source0: https://mirrors.aliyun.com/pypi/web/packages/df/5e/264d88c158244edb681760fe6be62c9bc2323baf6a0e882986536b1c4345/make-responsive-images-0.1.11.tar.gz
BuildArch: noarch
Requires: python3-Pillow
Requires: python3-typer
Requires: python3-colorama
Requires: python3-shellingham
%description
# `make-responsive-images`
Generate responsive images automatically, for websites to use `srcset` and `sizes` in the `` tags.
This way you serve an optimal image for each device viewport size.
## Installation
[Install from PyPI](https://pypi.org/project/make-responsive-images/)
```bash
pip install make-responsive-images
```
## Usage
```bash
resize [OPTIONS] COMMAND [ARGS]...
```
### Options
* `-v, --version`: Show the application's version and exit.
* `--help`: Show this message and exit.
## Commands
* `image`: Resize one image
### Usage
```bash
resize image [OPTIONS] [IMAGE]
```
### Arguments
* `[IMAGE]`: [default: /workspace/tests/fixtures/xfer-original.jpg]
### Options
* `--widths TEXT`: Widths of new images, in pixels [default: 600,1000,1400]
* `--html / --no-html`: Generate HTML tag [default: True]
* `--classes TEXT`: Classnames to add to the tag (e.g. class="img-fluid")
* `--img-sizes TEXT`: Sizes for the tag (e.g. sizes="100vw") [default: 100vw]
* `--lazy / --no-lazy`: Adds loading="lazy" to tag for SEO [default: False]
* `--alt TEXT`: Adds alt="" to the tag (e.g. alt="Funny image") [default: ]
* `--dir TEXT`: Images directory to prepend to the src (e.g. src="dir/image")
* `--fmt TEXT`: Image type to save as ("jpg" and "webp" supported) [default: webp]
* `--qual INTEGER`: Compression to apply (i.e. 0=max, 100=min) [default: 100]
* `--lower / --no-lower`: Converts filename to lowercase [default: True]
* `--dashes / --no-dashes`: Converts underscores to dashes for SEO [default: True]
* `--flask / --no-flask`: Uses Python Flask's 'url_for('static', ...)' [default: False]
* `--help`: Show this message and exit.
## Author Info
Sean McCarthy is Chief Data Scientist at [IJACK Technologies Inc](https://myijack.com), a leading manufacturer of fully-automated pumps to green the oil and gas industry.
%package -n python3-make-responsive-images
Summary: Generate responsive images for your website, so you can use srcset in your tags and serve an optimal image to each device that views your site.
Provides: python-make-responsive-images
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-make-responsive-images
# `make-responsive-images`
Generate responsive images automatically, for websites to use `srcset` and `sizes` in the `` tags.
This way you serve an optimal image for each device viewport size.
## Installation
[Install from PyPI](https://pypi.org/project/make-responsive-images/)
```bash
pip install make-responsive-images
```
## Usage
```bash
resize [OPTIONS] COMMAND [ARGS]...
```
### Options
* `-v, --version`: Show the application's version and exit.
* `--help`: Show this message and exit.
## Commands
* `image`: Resize one image
### Usage
```bash
resize image [OPTIONS] [IMAGE]
```
### Arguments
* `[IMAGE]`: [default: /workspace/tests/fixtures/xfer-original.jpg]
### Options
* `--widths TEXT`: Widths of new images, in pixels [default: 600,1000,1400]
* `--html / --no-html`: Generate HTML tag [default: True]
* `--classes TEXT`: Classnames to add to the tag (e.g. class="img-fluid")
* `--img-sizes TEXT`: Sizes for the tag (e.g. sizes="100vw") [default: 100vw]
* `--lazy / --no-lazy`: Adds loading="lazy" to tag for SEO [default: False]
* `--alt TEXT`: Adds alt="" to the tag (e.g. alt="Funny image") [default: ]
* `--dir TEXT`: Images directory to prepend to the src (e.g. src="dir/image")
* `--fmt TEXT`: Image type to save as ("jpg" and "webp" supported) [default: webp]
* `--qual INTEGER`: Compression to apply (i.e. 0=max, 100=min) [default: 100]
* `--lower / --no-lower`: Converts filename to lowercase [default: True]
* `--dashes / --no-dashes`: Converts underscores to dashes for SEO [default: True]
* `--flask / --no-flask`: Uses Python Flask's 'url_for('static', ...)' [default: False]
* `--help`: Show this message and exit.
## Author Info
Sean McCarthy is Chief Data Scientist at [IJACK Technologies Inc](https://myijack.com), a leading manufacturer of fully-automated pumps to green the oil and gas industry.
%package help
Summary: Development documents and examples for make-responsive-images
Provides: python3-make-responsive-images-doc
%description help
# `make-responsive-images`
Generate responsive images automatically, for websites to use `srcset` and `sizes` in the `` tags.
This way you serve an optimal image for each device viewport size.
## Installation
[Install from PyPI](https://pypi.org/project/make-responsive-images/)
```bash
pip install make-responsive-images
```
## Usage
```bash
resize [OPTIONS] COMMAND [ARGS]...
```
### Options
* `-v, --version`: Show the application's version and exit.
* `--help`: Show this message and exit.
## Commands
* `image`: Resize one image
### Usage
```bash
resize image [OPTIONS] [IMAGE]
```
### Arguments
* `[IMAGE]`: [default: /workspace/tests/fixtures/xfer-original.jpg]
### Options
* `--widths TEXT`: Widths of new images, in pixels [default: 600,1000,1400]
* `--html / --no-html`: Generate HTML tag [default: True]
* `--classes TEXT`: Classnames to add to the tag (e.g. class="img-fluid")
* `--img-sizes TEXT`: Sizes for the tag (e.g. sizes="100vw") [default: 100vw]
* `--lazy / --no-lazy`: Adds loading="lazy" to tag for SEO [default: False]
* `--alt TEXT`: Adds alt="" to the tag (e.g. alt="Funny image") [default: ]
* `--dir TEXT`: Images directory to prepend to the src (e.g. src="dir/image")
* `--fmt TEXT`: Image type to save as ("jpg" and "webp" supported) [default: webp]
* `--qual INTEGER`: Compression to apply (i.e. 0=max, 100=min) [default: 100]
* `--lower / --no-lower`: Converts filename to lowercase [default: True]
* `--dashes / --no-dashes`: Converts underscores to dashes for SEO [default: True]
* `--flask / --no-flask`: Uses Python Flask's 'url_for('static', ...)' [default: False]
* `--help`: Show this message and exit.
## Author Info
Sean McCarthy is Chief Data Scientist at [IJACK Technologies Inc](https://myijack.com), a leading manufacturer of fully-automated pumps to green the oil and gas industry.
%prep
%autosetup -n make-responsive-images-0.1.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-make-responsive-images -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.11-1
- Package Spec generated