%global _empty_manifest_terminate_build 0
Name:		python-sjcl
Version:	0.2.1
Release:	1
Summary:	Decrypt and encrypt messages compatible to the 'Stanford Javascript Crypto Library (SJCL)' message format.
License:	new-style BSD
URL:		https://github.com/berlincode/sjcl
Source0:	https://mirrors.aliyun.com/pypi/web/packages/16/70/68ec8c51690e450f878a22adea5e10c5e554cf6fa952de2240f1f5a4d484/sjcl-0.2.1.tar.gz
BuildArch:	noarch


%description
[![Travis CI](https://travis-ci.org/berlincode/sjcl.svg?branch=master&style=flat)](https://travis-ci.org/berlincode/sjcl)
[![Python versions](https://img.shields.io/pypi/pyversions/sjcl.svg)](https://pypi.python.org/pypi/sjcl/)
[![new-style BSD](https://img.shields.io/pypi/l/sjcl.svg)](https://github.com/berlincode/sjcl/blob/master/LICENSE.txt)
Decrypt and encrypt messages compatible to the "Stanford Javascript Crypto
Library (SJCL)" message format. This is a wrapper around pycrypto.
This module was created while programming and testing the encrypted
blog platform on cryptedblog.com which is based on sjcl.
Typical usage may look like this:
```python
    #!/usr/bin/env python
    from sjcl import SJCL
    cyphertext = SJCL().encrypt(b"secret message to encrypt", "shared_secret")
    print cyphertext
    print SJCL().decrypt(cyphertext, "shared_secret")
```

%package -n python3-sjcl
Summary:	Decrypt and encrypt messages compatible to the 'Stanford Javascript Crypto Library (SJCL)' message format.
Provides:	python-sjcl
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sjcl
[![Travis CI](https://travis-ci.org/berlincode/sjcl.svg?branch=master&style=flat)](https://travis-ci.org/berlincode/sjcl)
[![Python versions](https://img.shields.io/pypi/pyversions/sjcl.svg)](https://pypi.python.org/pypi/sjcl/)
[![new-style BSD](https://img.shields.io/pypi/l/sjcl.svg)](https://github.com/berlincode/sjcl/blob/master/LICENSE.txt)
Decrypt and encrypt messages compatible to the "Stanford Javascript Crypto
Library (SJCL)" message format. This is a wrapper around pycrypto.
This module was created while programming and testing the encrypted
blog platform on cryptedblog.com which is based on sjcl.
Typical usage may look like this:
```python
    #!/usr/bin/env python
    from sjcl import SJCL
    cyphertext = SJCL().encrypt(b"secret message to encrypt", "shared_secret")
    print cyphertext
    print SJCL().decrypt(cyphertext, "shared_secret")
```

%package help
Summary:	Development documents and examples for sjcl
Provides:	python3-sjcl-doc
%description help
[![Travis CI](https://travis-ci.org/berlincode/sjcl.svg?branch=master&style=flat)](https://travis-ci.org/berlincode/sjcl)
[![Python versions](https://img.shields.io/pypi/pyversions/sjcl.svg)](https://pypi.python.org/pypi/sjcl/)
[![new-style BSD](https://img.shields.io/pypi/l/sjcl.svg)](https://github.com/berlincode/sjcl/blob/master/LICENSE.txt)
Decrypt and encrypt messages compatible to the "Stanford Javascript Crypto
Library (SJCL)" message format. This is a wrapper around pycrypto.
This module was created while programming and testing the encrypted
blog platform on cryptedblog.com which is based on sjcl.
Typical usage may look like this:
```python
    #!/usr/bin/env python
    from sjcl import SJCL
    cyphertext = SJCL().encrypt(b"secret message to encrypt", "shared_secret")
    print cyphertext
    print SJCL().decrypt(cyphertext, "shared_secret")
```

%prep
%autosetup -n sjcl-0.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sjcl -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
- Package Spec generated