%global _empty_manifest_terminate_build 0
Name:		python-pepper8
Version:	1.1.1
Release:	1
Summary:	Transforms pep8 or flake8 output into an HTML report.
License:	MIT License
URL:		https://github.com/myth/pepper8
Source0:	https://mirrors.aliyun.com/pypi/web/packages/50/01/f59de4a56ac6a4245c710893938f6899acc4bf574b31e8937a456b519733/pepper8-1.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-Jinja2

%description


%package -n python3-pepper8
Summary:	Transforms pep8 or flake8 output into an HTML report.
Provides:	python-pepper8
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pepper8


%package help
Summary:	Development documents and examples for pepper8
Provides:	python3-pepper8-doc
%description help


%prep
%autosetup -n pepper8-1.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pepper8 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
- Package Spec generated