%global _empty_manifest_terminate_build 0 Name: python-space-rocks Version: 1.8.2 Release: 1 Summary: Python client for SsODNet data access. License: MIT URL: https://rocks.readthedocs.io/en/latest/ Source0: https://mirrors.aliyun.com/pypi/web/packages/75/ab/4b158357328237bfec441c012f64155421d95e8ef402e4193a39a90ba9c6/space_rocks-1.8.2.tar.gz BuildArch: noarch Requires: python3-numpy Requires: python3-numpy Requires: python3-matplotlib Requires: python3-aiohttp Requires: python3-faust-cchardet Requires: python3-aiodns Requires: python3-pandas Requires: python3-pydantic Requires: python3-rich Requires: python3-click Requires: python3-nest-asyncio Requires: python3-requests Requires: python3-Levenshtein Requires: python3-furo Requires: python3-sphinx-copybutton Requires: python3-sphinx_design Requires: python3-beautifulsoup4 Requires: python3-platformdirs Requires: python3-rapidfuzz %description

Features - Install - Documentation



## Features Explore asteroid data on the command-line... ``` sh $ rocks id 221 (221) Eos $ rocks class Eos MB>Outer $ rocks albedo Eos 0.136 +- 0.004 $ rocks taxonomy Eos K $ rocks density Eos 4.559e+03 +- 1.139e+03 kg/m$^3$ ``` ... and in a `python` script. ``` python >>> import rocks >>> rocks.identify("1902ug") ('Fortuna', 19) >>> ceres = rocks.Rock("ceres") >>> ceres.diameter.value 848.4 >>> ceres.diameter.unit 'km' >>> ceres.mass.value 9.384e+20 >>> ceres.mass.error 6.711e+17 ``` ## Install Install from PyPi using `pip`: $ pip install space-rocks The minimum required `python` version is 3.7. ## Documentation Check out the documentation at [rocks.readthedocs.io](https://rocks.readthedocs.io/en/latest/) or run $ rocks docs %package -n python3-space-rocks Summary: Python client for SsODNet data access. Provides: python-space-rocks BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-space-rocks

Features - Install - Documentation



## Features Explore asteroid data on the command-line... ``` sh $ rocks id 221 (221) Eos $ rocks class Eos MB>Outer $ rocks albedo Eos 0.136 +- 0.004 $ rocks taxonomy Eos K $ rocks density Eos 4.559e+03 +- 1.139e+03 kg/m$^3$ ``` ... and in a `python` script. ``` python >>> import rocks >>> rocks.identify("1902ug") ('Fortuna', 19) >>> ceres = rocks.Rock("ceres") >>> ceres.diameter.value 848.4 >>> ceres.diameter.unit 'km' >>> ceres.mass.value 9.384e+20 >>> ceres.mass.error 6.711e+17 ``` ## Install Install from PyPi using `pip`: $ pip install space-rocks The minimum required `python` version is 3.7. ## Documentation Check out the documentation at [rocks.readthedocs.io](https://rocks.readthedocs.io/en/latest/) or run $ rocks docs %package help Summary: Development documents and examples for space-rocks Provides: python3-space-rocks-doc %description help

Features - Install - Documentation



## Features Explore asteroid data on the command-line... ``` sh $ rocks id 221 (221) Eos $ rocks class Eos MB>Outer $ rocks albedo Eos 0.136 +- 0.004 $ rocks taxonomy Eos K $ rocks density Eos 4.559e+03 +- 1.139e+03 kg/m$^3$ ``` ... and in a `python` script. ``` python >>> import rocks >>> rocks.identify("1902ug") ('Fortuna', 19) >>> ceres = rocks.Rock("ceres") >>> ceres.diameter.value 848.4 >>> ceres.diameter.unit 'km' >>> ceres.mass.value 9.384e+20 >>> ceres.mass.error 6.711e+17 ``` ## Install Install from PyPi using `pip`: $ pip install space-rocks The minimum required `python` version is 3.7. ## Documentation Check out the documentation at [rocks.readthedocs.io](https://rocks.readthedocs.io/en/latest/) or run $ rocks docs %prep %autosetup -n space_rocks-1.8.2 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-space-rocks -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 1.8.2-1 - Package Spec generated